Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Aug 2018
    Posts
    10

    XL5 red/green flashing lights

    I have tried to search this with no good answer so I am looking for a hand. I just picked up a new Mustang GT 4-TEC. I have a venom 5000mah 35c 11.1v lipo. When I plug it in the lights on the XL5 flash red/green and only the steering servo works. I have tried to make sure the LVD is on, but it immediately goes back to the red/green flash. When I plug in an old NIMH everything works fine. Any thoughts?

  2. #2
    Traxxas Employee TraxxasMacgyver's Avatar
    Join Date
    Aug 2018
    Posts
    21
    Hey 04warrior, The XL5 only takes up to a 2s Lipo or a 7cell NiMh. YOur ESC is going into Overvoltage protection.

  3. #3
    RC poster
    Join Date
    Aug 2018
    Posts
    10
    Well crap....I thought I read something about 12+- volts. Hmmm...do I return the battery or go brushless? Thank you

  4. #4
    RC Champion
    Join Date
    Apr 2018
    Posts
    1,042
    I would go brushless. That is JMO. You’ll have a much more efficient setup by going brushless as well. There are many companies making good ESC/motor combo sets. Just do fine homework and get something you can grow into power wise.

  5. #5
    RC poster
    Join Date
    Aug 2018
    Posts
    10
    I decided to grab a 2s for now. May be I will do the change over the winter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •