Results 1 to 6 of 6
  1. #1
    RC Enthusiast
    Join Date
    May 2003
    Location
    PA
    Posts
    24

    Sport Maxx engine help...

    Hey everyone I need some help, BIG TIME. I just bought a Sport Maxx a week ago. I ran through the break in period as stated by the manual, but a ran into some problems yesterday.
    I took it out yesterday to fine tune it since i couldn't run it the day or so after the break in due to major snow. But I did do an afterrun treatment.
    Anyways, I took it out and started it up, and it ran ok i made a couple passes and it stalled. So i brought it in and richend it up a bit, high and low needle. I figured it needed it since it's been really cold here. It started up again and i made another pass but it stalled again. This time though the glow plug light came on, on the easy start. I took it off and the whole thing was burnt. The coil was gone and everything. So i took it home cause i didnt have any extra plugs with me. I went to do an afterun treatment again at home, but the engine wont crank. I'm pretty sure the battery has plenty of juice in it it was enough to start it twice, although it was sitting for a day before hand.
    I'm just wondering what the problem might be. This is my first nitro and it's giving me headaches already. I'm hoping i didnt sieze the engine up or anything. Any help or info is appreciated.
    THANKS

  2. #2
    RC Qualifier
    Join Date
    Oct 2003
    Location
    MN
    Posts
    279

    Re: Sport Maxx engine help...

    Originally posted by NeO GoD GiNrAi
    This is my first nitro and it's giving me headaches already. THANKS
    ... and many more to come Just remember its a hobby and half the fun is working on it!

    I'm a little confused as to what your actual questions are but this is what I think you are asking.

    1) Why does it stall?

    2) Why wont the EZstart turn over my engine?

    1) I think the biggest problem was that your glow plug was cooked. It might have needed a little tuning due to the cold, you are right there, but I would get a new plug and go back to factor settings. Tune from there. Usally when I stall out in the cold like this its a LSN or Idle adjustment as it never stalls on a high speed pass only when I try to idle.

    2) Could have flooded the engine while you were tinkering. Try and clear the engine as stated in your manual. Also see if yo ucan slip your finger upto the main crank gear (before the clutch) and try to spin the engine by hand.

    Good luck!

    ps. Use the Search button !
    Last edited by morganm; 12-08-2003 at 09:20 AM.
    Don't drive like my brother!

  3. #3
    RC Champion
    Join Date
    Nov 2003
    Location
    florida
    Posts
    1,127
    for 1 thing it might be ur batts or ue ezstart is in safe mode and the plugs coil being gone that probably runn int too lean

  4. #4
    RC Enthusiast
    Join Date
    May 2003
    Location
    PA
    Posts
    24
    I charged the battery pack and it's still not working. Just a couple clicks and then then the motor light wont even come on ( the glow plug isnt connected right now). I cant reach the main crank gear, but i tried to turn the flywheel and it wont budge at all. Does this mean the engine seized up? If so how do I go about fixing it. I assume I'd need a new piston and sleeve. How much do they cost usually??

    P.S.- sorry if this is one of those repeated newbie threads, I did try searching but it didnt come up with much useful info.

  5. #5
    RC Enthusiast
    Join Date
    May 2003
    Location
    PA
    Posts
    24

  6. #6
    RC Racer
    Join Date
    Nov 2003
    Location
    Dibble OK
    Posts
    112

    Lightbulb

    Mine pulls this sort of tantrum sometimes turn your truck upside down to get all the unused nitro out of the crank case, If that does not work take your head off and use something like a screwdriver on the flywheel (silver thing behind the clutchbell) put the flathead screwdriver on one of theridges and push. The worst case scenario take of your head, fuel line into the carb get it unflooded, spray with wd 40 and let soak maybe if that doesnt work contact customer service and talk to them as it might be a warranty issue.
    Forgiveness is easier to obtain than permission. If you want to know my AIM SN then pm me Moderators dont like it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •