Results 1 to 8 of 8
  1. #1
    RC Racer
    Join Date
    Aug 2001
    Location
    NYC
    Posts
    113

    Clutch issue or other?

    Gotta question (I apologize if it was asked earlier in this forum)

    My maxx is equipped with a 18 CV-R, and I ws running it today and as I was driving it today, the engine reved higher and the truck wasnt' moving much and started to slow down. I stopped the truck and tried to accelerate the truck again and the engine revved high again and the truck barely moved. The diffs don't feel like they are busted (the wheels move in opposite directions when I rotate them, and feel as if they are working). I took the tranny apart and the gears look good, so I'm guessing it's the clutch is slipping. Does this sound like a correct diagnosis?

    I should tell you that the clutch shoes/spring ar the stock ones that came with the truck (2.5 I got new over a year ago, and ran 3 gallons through the original engine). I'm guessing its the clutch also because it's just old. How does the MIP clutch do in the maxx? that's what I'm looking at.

    thanks in advance

  2. #2
    RC Qualifier
    Join Date
    Mar 2005
    Location
    London
    Posts
    271
    Sounds to me like the slipper pegs may be worn. I would try replacing them first.
    Back once again, its the Renegade Master

  3. #3
    RC Racer
    Join Date
    Aug 2001
    Location
    NYC
    Posts
    113
    never thought of looking at the slipper pegs, thanks!

  4. #4
    RC Turnbuckle Jr. ip42800ht's Avatar
    Join Date
    Dec 2004
    Location
    San Jose, California
    Posts
    3,491
    It may be the slipper pegs.


    Even thoguh, upgrade to thr MIP clutch. It's great. More torque off the line. Plus, it has two settings. Heavy and light. For $15, it's a steal.

  5. #5
    RC Racer
    Join Date
    Aug 2001
    Location
    NYC
    Posts
    113
    might sound stupid but is there an easy way to tell if the pegs are shot?

  6. #6
    RC Qualifier
    Join Date
    Mar 2005
    Location
    London
    Posts
    271
    might sound stupid but is there an easy way to tell if the pegs are shot?
    Actually I am not too sure myself. I guess have a look at them and see if any of the material is proud of the spur gear (ie have the pegs been worn down smooth to the surface of the spur).

    I know when I last changed my pegs they stuck out a little on either side. I am actually thinking of changing to ball bearings next time they need replacing, as per this article at Misbehavins site.
    Back once again, its the Renegade Master

  7. #7
    RC Racer
    Join Date
    Aug 2001
    Location
    NYC
    Posts
    113
    Well it looks like it was the pegs. I took off the spur and found the back of it messed up. I took out the old pegs, cleaned up the holes as best I could, and it look like the spur gear could be used again. I may try that ball diff balls trick, thanks for the help.

  8. #8
    RC Qualifier
    Join Date
    Mar 2005
    Location
    London
    Posts
    271
    No worries
    Back once again, its the Renegade Master

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •