Results 1 to 6 of 6
  1. #1
    RC Racer
    Join Date
    Feb 2003
    Location
    Illinois
    Posts
    174

    I think i got a......

    Bad news i think i have a short somewhere in my system because my reciever battery does not hold a charg it goes in like 2 min the servos don't fight each other every thing is stock

  2. #2
    RC Qualifier
    Join Date
    Apr 2005
    Location
    vancouver wa
    Posts
    455
    Unhook servos one at a time to try to isolate issue. if it lasts with one or the other unhooked you could have found the issue. One at a time is the key.

  3. #3
    RC Competitor
    Join Date
    May 2005
    Posts
    99
    is it new if so you are getting false peaks let it charge over night the first time then it will be ok if it is not new trouble shoot it your bat may be dieing or you have servos that chatter good luck

  4. #4
    RC Competitor
    Join Date
    Apr 2005
    Location
    Alabama.......Down South Jukin'
    Posts
    93
    is there anything loose or rattaling in or on ur car? is it wen u drive it, or just turn on?
    o.s.18 tm REVO!! AIM=csaflive

  5. #5
    RC Racer
    Join Date
    Feb 2003
    Location
    Illinois
    Posts
    174
    i think it may be the charger at least i hope so it is no new and i just rebuilt the whole truck i found out i have some gears messed up in my tranny and my slipper pads are gone except 1.5

  6. #6
    RC Racer
    Join Date
    Nov 2004
    Location
    Omaha, NE
    Posts
    203
    Originally posted by fasttrax
    is it new if so you are getting false peaks let it charge over night the first time then it will be ok if it is not new trouble shoot it your bat may be dieing or you have servos that chatter good luck
    gotta agree with fasttrax, this is a common prob with Revo owners...
    New to Cars, Old to Planes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •