Results 1 to 9 of 9
  1. #1
    RC Competitor
    Join Date
    Mar 2009
    Posts
    94

    My Smaxx Wont Run Either

    As Title Says

    I Use My Ez Start And Motor Just Spins And Spins

    Glow Plug Is Good Compression Is Good.

    I Checked Fuel Lines No Leaks.

    Cant See Any Fuel Run Through The Lines......help!!
    if it aint broke,you aint having fun!

  2. #2
    RC Qualifier
    Join Date
    Apr 2009
    Posts
    380
    Plug the exhaust pipe, turn the engine over with the EZ start for 2-3 seconds. Unplug exhaust, start normally use 5-10 second burst to start, don't sit and hold it. Pumping the throttle a little helps. Just don't gun it.

  3. #3
    RC Competitor
    Join Date
    Mar 2009
    Posts
    94
    I HAVE TRIED THIS ALSO.

    THERE ARE NO AIRLEAKS EITHER.
    if it aint broke,you aint having fun!

  4. #4
    RC Competitor
    Join Date
    Mar 2009
    Posts
    94
    nobody? anybody?
    if it aint broke,you aint having fun!

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Jul 2008
    Location
    Chicago
    Posts
    5,114
    Quote Originally Posted by hawxter996
    nobody? anybody?
    Check/Clean/Replace::::

    Fuel tank (orange cap/lid gasket) for any distortion or cuts. This would make for no seal and no fuel getting in the line.
    Take the return line off the pipe and clean it out or replace it. Clean out the nozzle on the tank lid and the pipe with a pipe cleaner..
    Look at the fuel filter inside the tank for debris and clean it out.
    Replace the fuel line and return line anyway, it's only a buck or 2..
    Keep flex'in those forum keyboard muscles.

  6. #6
    RC Competitor
    Join Date
    Mar 2009
    Posts
    94
    I fixed it!



    hey guys thanks for the help!


    all this advice has been filed for future reference.

    my problem? need to run to LHS.


    fuel jug is empty!


    thanks again though,these replies will most likely help in the future.
    if it aint broke,you aint having fun!

  7. #7
    RC Turnbuckle Jr.
    Join Date
    Jul 2008
    Location
    Chicago
    Posts
    5,114
    Quote Originally Posted by hawxter996
    I fixed it!



    hey guys thanks for the help!


    all this advice has been filed for future reference.

    my problem? need to run to LHS.


    fuel jug is empty!


    thanks again though,these replies will most likely help in the future.

    Yeah real cute See if you get any help from me and i hope no one in the future..
    Nice way to waste bandwidth and our time... Go play on yahoo not here kid...
    Last edited by got_nitro; 05-16-2009 at 08:19 AM.
    Keep flex'in those forum keyboard muscles.

  8. #8
    RC Competitor
    Join Date
    Mar 2009
    Posts
    94
    ok as long as you go play with your toys also....kid!
    if it aint broke,you aint having fun!

  9. #9
    Marshal
    Join Date
    Mar 2003
    Posts
    3,475
    This is about to get out of hand.
    Thread closed.
    Look out buggies....Revo 3.3 coming through!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •