Results 1 to 12 of 12
  1. #1
    RC Racer
    Join Date
    Apr 2009
    Posts
    204

    Well this sucks...

    My Revo vxl has some major clogging issues. Talked to TRX support they couldnt help me they just said send it in. I had to take the receiver, esc, and servo out which took a bit long for me. And TRX didnt cover shipping costs which sucks for a person living in Canada it costed me $15 for 12 day shipping. Im going to be out of an rc for atlest a month probably. Then when I receive it pop all that stuff bag in (hassle). Funny thing is the car is a day old with two runs. Wow if they send the stuff back saying they replaced/repaired the products and that it should work im not going to be happy

  2. #2
    RC Qualifier
    Join Date
    Apr 2009
    Location
    Codova, TN
    Posts
    868
    yeah that does suck!!!
    MMP-NEU 1112 1.5D 4S MERBE
    BEAST MODE [ON] OFF

  3. #3
    RC Qualifier
    Join Date
    Apr 2009
    Location
    Edmonton, Alberta
    Posts
    296
    Quote Originally Posted by ////AMG
    Wow if they send the stuff back saying they replaced/repaired the products and that it should work im not going to be happy

    um what are you wanting from them? lol
    Revo 3.3, 5308

  4. #4
    RC Racer
    Join Date
    Apr 2009
    Posts
    204
    Meant to say doesnt

  5. #5
    RC Turnbuckle Jr. Carbonrevo33's Avatar
    Join Date
    Jul 2008
    Location
    In a box on Hwy. 64 bashin' with Bradley Youngskins!
    Posts
    3,979
    wow, that sucks man. Sorryto hear that. Hopefully you get it sooner than you hoped.

  6. #6
    RC Racer
    Join Date
    Apr 2009
    Posts
    204
    I was thinking I might aswell do something while I got the month off. Dye the chasis black?

  7. #7
    RC Qualifier
    Join Date
    Aug 2007
    Posts
    383
    Sorry to say this but I am beginning to think that your problem is operator error : ). You seem to be having all the problems.

  8. #8
    RC Champion
    Join Date
    Aug 2006
    Location
    Renton, WA
    Posts
    1,968
    Sorry to hear it's clogged.
    ------
    hmmm, I've never seen it spelled that way.

  9. #9
    RC Racer
    Join Date
    Apr 2009
    Posts
    204
    Quote Originally Posted by Carguy
    Sorry to say this but I am beginning to think that your problem is operator error : ). You seem to be having all the problems.
    This is the only problem I had [Insert Swear]

  10. #10
    RC Qualifier
    Join Date
    Sep 2008
    Location
    Stockton, Ca.
    Posts
    928
    Quote Originally Posted by ////AMG
    This is the only problem I had [Insert Swear]
    I think your problem's legit, Check out this post its long but you might find something you can use

    http://monster.traxxas.com/showthread.php?t=467664

  11. #11
    RC Qualifier
    Join Date
    Jun 2009
    Location
    Southern New Hampshire
    Posts
    349
    Radical,
    That thread you mentioned went on forever, at least the problem was eventually fixed
    HPI Savage LOSI Mini/MicroT, MRC Traxxas Revo VXL

  12. #12
    RC Competitor
    Join Date
    Jun 2009
    Location
    West Coast Central Florida
    Posts
    91
    FYI, The term is "COGGING"
    (2)E-LST's(2)E-Lightning Stadium Pro2's(3)E-Revo's

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •