Results 1 to 6 of 6

Thread: MotorWoes...

  1. #1
    RC Racer
    Join Date
    Oct 2009
    Location
    Browns Summit, NC
    Posts
    187

    MotorWoes...

    Sooooo i decided id try out a venom 15d fireball..... gearing 16/86

    wow it was faster .. notice I say was .... well one full pack 7 cell 3000 mah traxxas battery and not even 1/4 way thru my Promatch 4600 7 cell and smoke was coming from the motor .. it was so hot the positive wire came unsoldered ....

    Hopefully wheni re solder it it still works, .. if not oh well 15 bucks poooo
    Zach
    Slash 2wd-RPM/STRC
    Stampede

  2. #2
    RC Enthusiast
    Join Date
    Mar 2010
    Posts
    26
    yeah sounds like the 15t HPI i got. the negative wire broke up at the connector and then it broke at the motor. fixed both of them and i think the motor is burnt up... but it was only $6 shipped off e-bay and it lasted about a month so i didn't to to bad i dont guess..

  3. #3
    RC Competitor
    Join Date
    Apr 2010
    Location
    Grand Rapids, MI
    Posts
    88
    If it lived you need to gear it down some, compared to the Titan it has no where near the torque but does turn more rpm...
    MoD SLaSH - 10.5T - 2S - Hellbent LCG Chassis

  4. #4
    RC Racer
    Join Date
    Oct 2009
    Location
    Browns Summit, NC
    Posts
    187
    ya, i figured 16 tooth from 19 was a good drop, apparently not .. i dont think its gonna work once i get it resoldered, as once it cooled down, i stuck the pos wire back on temporarily .. and once i went to throttle smoke started coming from the motor ..
    Zach
    Slash 2wd-RPM/STRC
    Stampede

  5. #5
    RC Qualifier
    Join Date
    Jun 2009
    Posts
    583
    thats exactly what happened to my orion it worked with my 6 cell but came unsoldered with the promatch 4600

  6. #6
    RC Turnbuckle Jr. CarGuy7a's Avatar
    Join Date
    Dec 2008
    Location
    Gettin' Lucky In KY
    Posts
    3,917
    Most likely your gearing is what fried the motor. I couldn't imagine a 15T 540 lasting very long in a heavy slash especially geared 16/86. Not to mention the Venom motors aren't the best out there.

    For a 15T 540 motor you should have been running a 12 or 13 tooth pinion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •