Results 1 to 38 of 38
  1. #1
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231

    Not Happy At This Moment... Need Help.

    I finally ran my brand new ERBE today, for about 2 minutes. I was only trying to break in the slipper (per the instructions) using the included nimh batteries. After about 2 minutes it quit running. It make a "cogging" noise and sort of spazzes out. I also notice the batteries where hot as well as the esc wires. Any help out there?
    <<Everything is FOR SALE>>

  2. #2
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    LiPo voltage cut-off maybe?
    <<Everything is FOR SALE>>

  3. #3
    RC Champion
    Join Date
    Jun 2008
    Location
    Winnipeg, Canada
    Posts
    1,048
    Ahh I think it might be done..

    My tekin did the same thing before it burst into flames

    ESC wires were hot, motor wires were hot, lipo wires were hot, and it made the same cogging type sound

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,777
    What gearing were you running ( stock I guess )? What kind of driving were you doing to 'break in the slipper' ( thats a new one for me.... )?

    Do you have a castlelink to check the esc settings?

    Have you tried different/ recharged batts?

    Do you have a temp gun to check the actual esc & motor temps?
    Keeping the Mods busy is my specialty...

  5. #5
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Stock out of the box... charged the 7-cells that came with it and drove it back and forth in front of my house, per the break in instructions that came in the box, and it only ran for 2 minutes max. I do not have a castle link, but I will order one asap. I tried some other batteries I have, fully charged, and it did the same thing. I am going to try and turn off LiPo low voltage cut off and see if it helps, unfortunately the instructions are not clear in how to do it. Not real happy so far...
    <<Everything is FOR SALE>>

  6. #6
    RC Champion
    Join Date
    Jun 2008
    Location
    Winnipeg, Canada
    Posts
    1,048
    Ohh yeah, you have to turn off the lipo lvc when running nimhs

    Its probably fine.

  7. #7
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Can it be done without the castle link?
    <<Everything is FOR SALE>>

  8. #8
    RC Turnbuckle Jr. streetdemon's Avatar
    Join Date
    Jun 2003
    Location
    The home of the brave....
    Posts
    3,117
    Yeah, there should be directions somewhere included on how to do it. You need to enter manual programming mode and use the throttle for "yes" and "no" responses and by listening to the beeps you can get it out of lipo mode.
    Some like R/C's that are fast, others like nitro

  9. #9
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    7,181
    here's the instructions:

    http://www.castlecreations.com/suppo...s_ed_guide.pdf

    starts on page 20.
    One mans garbage is another mans ungarbage" -Ricky

  10. #10
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    I think the esc is fried. I tried to go through the whole manual set up process to turn off the lvc, but I can't even get into calibration mode. I hold the throttle and wait for the second set of four beeps but it just keeps beeping and the front wheels move back and forth. Also the batteries get hot when I do this, so I figure the esc is just fried. ABSOLUTELY SUCKS! Pay a bunch of money for something... wait for it to show up... and it's BROKEN! It would be an understatement to say I am frustrated.
    <<Everything is FOR SALE>>

  11. #11
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    There is a separate page of information in the box from TRAXXAS that says you should break in the slipper. Basically it says to drive the truck normally using the included batteries, or a max of 2s lipos. I guess you are supposed to do this for a few cycles before unleashing on 3s lipos.
    <<Everything is FOR SALE>>

  12. #12
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    When I get this thing fixed I think having a castle link would be helpful, but I don't see how it plugs in, any body using the cable?
    <<Everything is FOR SALE>>

  13. #13
    RC Qualifier
    Join Date
    Jun 2008
    Location
    Catskill, NY
    Posts
    737
    The cable plugs into the plug off the esc that you insert into the receiver and the other end gets plugged into a usb slot on your comp.

    Sorry you had this happen. This hobby is nothing but let downs at times.
    Id email castle today. Ask if you can pick up a new esc somewhere near you, so you dont have such a long downtime to mail it in and get it returned. Also, you could get intouch with the place you bought it from and see what they can do for you...

  14. #14
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    There is also a cable you can install permanently so that you don't have to open the receiver box every time, right? Might need to get that too. I think I am also going to get a couple of 2s lipos and skip the nimh packs when I get it fixed.
    <<Everything is FOR SALE>>

  15. #15
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,777
    You're thinking of a servo Y-splitter- plug it into the throttle channel on the rx, plug the esc into that, and leave the spare connector dangling out the rx box... hmm.. you tend to only use the castlelink very rarely ( intial setup & a couple of fine tuning tweaks maybe ), I wouldnt worry/bother about extra cables as it just creates less space inside the rx box.
    Keeping the Mods busy is my specialty...

  16. #16
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Hmm, you have a good point.
    <<Everything is FOR SALE>>

  17. #17
    RC Qualifier
    Join Date
    Jul 2006
    Location
    Planet Earth
    Posts
    928
    I use this cable extender. That sucks big time indeed. And I don't think LVC has anything to do with this. IIRC LVC is not even on by default with these brushless version trucks shipped (could be wrong though) ;and the batts. wouldn't die in 2 mins.

    When I first got my EMBE I ran it w/ the included NIMHs for a full run til' the batts. died. I think you were just unlucky. Might be time to call Castle.

    BTW here's a very nice thread about info. on the CC Link etc.
    Last edited by makaveli72; 08-28-2010 at 07:47 PM.
    **I hope there are RCs in Heaven; EMBE + 6S FTW!**

  18. #18
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    7,181
    you might wanna call castle ASAP. i know they just got in a big shipment of escs, but i don't know how long they're gonna last. mine sat there for 6 weeks waiting on new stock, and i just got the 2 new replacements today.
    One mans garbage is another mans ungarbage" -Ricky

  19. #19
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Thanks for the info guys, I have an email in with them and I will follow up with a call on Monday.
    <<Everything is FOR SALE>>

  20. #20
    RC Qualifier
    Join Date
    Mar 2010
    Location
    Bloomington, Minnesota
    Posts
    394
    Castle has stellar customer support, right up there with traxxas itself. I have read many stories of MMMs being DOA (or ends up dying on the first run) in ERBE's, and castle sending the person a new ESC, no q's asked. I would just call them now, they are not that quick with emails it took them 4 days to reply to a question I sent them.

    Good luck!
    _____________________
    ERBE/RUSTY VXL/ALIAS

  21. #21
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    I will definitely call them Monday, as they are only open Monday - Friday 9am 10 5pm.
    <<Everything is FOR SALE>>

  22. #22
    RC Qualifier
    Join Date
    Mar 2010
    Location
    Bloomington, Minnesota
    Posts
    394
    Quote Originally Posted by IM4RC
    I will definitely call them Monday, as they are only open Monday - Friday 9am 10 5pm.
    Sorry, duh.
    Again, good luck.
    _____________________
    ERBE/RUSTY VXL/ALIAS

  23. #23
    RC Qualifier
    Join Date
    Jul 2009
    Location
    Melbourne, Australia
    Posts
    622
    I can't believe that Traxxas still include Ni-MH batts with the ERBE. Ni-MH batts are going to be nothing but a disaster with such a big amp hungry system like MMM. Why Traxxas? Castle recommends minimum of 120A (I think?) discharge ability from the batts and the included Ni-MH (or just about any other brand) would be luck to hold a third of that for more than half a second. Seriously would be better off not even making the ERBE as a RTR. Lower the price by what ever the 7 cell Ni-MH cost and sell it like that.
    BASH. BREAK. FIX. REPEAT. ALWAYS REPEAT.

  24. #24
    RC Qualifier
    Join Date
    Jul 2010
    Posts
    438
    its prob yr esc
    i had similar prog
    day i got it did not work ****sseeeddd off especially after spending 1g
    but thems the breaks
    had one good drive and thats it then had to take it back to lhs
    then guys on here told me its a month wait for new esc so i said f that
    so i went a bought a new esc and its been good ever since
    im still waiting for my warranty esc
    i would seriously like to know the stuff up ratio on the castle esc
    as afew guys have had probs lately
    hey big block could the nimhs cause issues
    like imagine if the mmm needs all this grunt but the ****y nimh cant produce it

    might be worth seeing how many newish mmm esc's fail using nimhs
    and how many on lipos

    i think the local hobby shops should keep 2 mmm esc spare
    then there would not be so many unhappy customers
    anyway better not complain too much on this forum

  25. #25
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    I will bet 10 to 1 the LHSs in my area will not have an esc. I am at the mercy of the guys at Castle.

    From another angle... If I don't want to wait and buy one from Tower it will be a v3, will that make a difference?
    <<Everything is FOR SALE>>

  26. #26
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Castle is sending a complete system. Very happy with the customer service, just need to see when it will ship. Their recommendation was to only run the truck on lipos. So, I guess I will need to get some on order.
    <<Everything is FOR SALE>>

  27. #27
    RC poster
    Join Date
    Aug 2010
    Posts
    2
    Glad to hear that you are getting a new setup, I just had the same thing happen to me. Was a real pain to see things go up in smoke after time and money on my install.

  28. #28
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Looks like CC has some in stock. I am hopeful that they will ship it tomorrow. Now to get some LiPos.
    <<Everything is FOR SALE>>

  29. #29
    RC Qualifier
    Join Date
    Jul 2009
    Location
    Melbourne, Australia
    Posts
    622
    Quote Originally Posted by IM4RC
    Castle is sending a complete system. Very happy with the customer service, just need to see when it will ship. Their recommendation was to only run the truck on lipos. So, I guess I will need to get some on order.
    Thats exactly what I was getting at. Traxxas should know better. Castle have always stated that Ni-MH batts can hurt the ESC badly and do not recommend running them at all with the MMM. I think it is even on their website. Still Traxxas insists on putting their Ni-MH batts with the ERBE for what ever reason. Not an issue for me really as I would just sell them but those who don't know better will try to run their truck with them and eventually do damage to their ESC. Then Castle has to pick up the bill and send out a new ESC to the Traxxas customer. That make sense to anyone?
    BASH. BREAK. FIX. REPEAT. ALWAYS REPEAT.

  30. #30
    RC Competitor
    Join Date
    Aug 2010
    Location
    Silver Spring, MD
    Posts
    52
    I just had the EXACT same thing happen -- running the same set up as you. Red plug coming from ESC probably shorted out your battery connector. I had to send in my ECS just yesterday. Took two weeks to get someone on the phone. You are lucky.

  31. #31
    RC Racer
    Join Date
    Apr 2010
    Posts
    130
    Just an FYI, you cannot use a Y-Harness to calibrate the MMM with a pc. The receiver needs to be completely disconnected for the Castle Link to detect the MMM Esc. You can buy the Castle Link "Quick Connect" which will work without disconnecting from the receiver. Or just use an extender like the one makaveli72 said earlier.

  32. #32
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    The one thing that I can say is that CC has been great as far as customer service goes. I got a confirmation email today that my replacement has shipped! Now I am really in a pinch to decide what LiPos to get. I know I want 2s 5000mah 35c or better, and I don't want to modify the battery or chassis to get them to fit. As anyone can tell that debate rages on in multiple threads a week! lol I kind of like the set-up Tank250 showed in his thread, but in a 2s configuration. We'll just have to see what looks best.
    <<Everything is FOR SALE>>

  33. #33
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,777
    Dont fear trimming the battery doors a little, it really isnt a big deal- lipos most likely to fit will be ones with the wires exiting the corner, then just trim a notch in the door as required ( if at all ). Be brave
    Keeping the Mods busy is my specialty...

  34. #34
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    It's down to ******* (ebay) or Venom (Tower). The plus to going with Venom packs is I can get a Castle link on the same order. and save $25 on the whole order. About $145 for 2 packs and the cable. I am pondering it at this very moment... hmmm.
    <<Everything is FOR SALE>>

  35. #35
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,777
    Never venoms have been working quite well by all accounts, not such a bad choice these days- prices are about average it seems..
    Keeping the Mods busy is my specialty...

  36. #36
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    Never venoms??
    <<Everything is FOR SALE>>

  37. #37
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,777
    Newer venoms even, I cant type when Im tired... :P
    Keeping the Mods busy is my specialty...

  38. #38
    RC Racer
    Join Date
    Dec 2009
    Location
    Niceville, FL
    Posts
    231
    I understand AoD... thanks for all of your help!
    <<Everything is FOR SALE>>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •