Results 1 to 19 of 19
  1. #1
    RC Racer
    Join Date
    Jul 2010
    Posts
    182

    Angry Lost all control !

    Had a beautiful day her in NH... 60+ and sunny This is the second time the boat has been in the water. I've done the cooling mods;water jacket, 1/8th ID hose,and opened up the rudder pick up and the outlet. Ran it for 5 minutes and brought it in to the dock to check the temps and all was good... motor was 101 at the top,jacket was 64 and bottom(shaft end) was 76. Put the boat back in the water and pulled the trigger lost all control,couldn't turn,couldn't stop straight into a group of telephone poles used to dock the Mount Washington. I ran over to the local scuba shop and grabbed a kayak and paddel and went to get it. Wish I had a camera or cell phone with me It was stuck in between two of the poles and the bow was wide open. If it hadn't been stuck, it would have sank in about 20' of ice cold water. Pictures to follow.

    SOMEBODY CALL THE WAMBULANCE

  2. #2
    RC Qualifier
    Join Date
    Nov 2006
    Posts
    532
    was it full throttle stuck?

  3. #3
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    It looked that way. Just took off. All I could see was the roostertail and then a very loud SMACK!!!! It ran for a few more seconds and then stopped.

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Nov 2006
    Location
    USA
    Posts
    3,138
    Oh man!!!
    we Spartan owners are so sorry to hear this..
    First MiniSlash
    HK6XL Revo 4s 60mph Amsoil dealer

  5. #5
    RC Qualifier
    Join Date
    Apr 2005
    Location
    Tennessee
    Posts
    658
    Thats no way to start your boating day. Sorry to hear it. Hope you can get things sorted out.
    Land, Sea & Air, A true RC Addict

  6. #6
    RC Qualifier
    Join Date
    Dec 2010
    Location
    Canada
    Posts
    531
    Sorry to here about this. not good when large amounts of damage happen.

    I had the same thing happen to a 1/5 scale gas buggy. Took off at full throttle, no steering. Wide open area with 1 metal light standard in the vicinity. Of course the buggy had to hit the pole square on, couldn't miss it and end up in the tall grass and brush on the perimeter that would have stopped it or slowed it down before hitting the chain link fence.

    Luckily there were no people around that might have been hit, and the damage was surprisingly less than expected. It never ran right after that though.

    The point is, I have felt your pain.

    Kevin

  7. #7
    RC poster
    Join Date
    Mar 2011
    Location
    Snohomish, WA
    Posts
    8
    OUCH! I, too, had that happen to my RC helicopter: just took off from me like someone else was controlling it: it's supposed to come down when it loses a signal or gets conflicting signals. 1/8 mile later a wind gust turned it upside down (about 150' high at that point) and slammed it full speed into the tarmac at the airport I was at. Needless to say it took ALOT of parts to fix. matter of fact, the only parts I didn't have to replace were the engines themselves, servo, and.... I think the ... nope, had to replace that... hmm, thing that was it. $$$$

    Speaking of airport: couple of my avionics buddies had warned me my frequency could get jammed by the radar and landing signal systems in use there. Could the Washington have been running it's radar when you lost control?
    Last edited by Sticks n Stones; 03-17-2011 at 10:24 PM.

  8. #8
    RC Champion djmaincheese's Avatar
    Join Date
    Jan 2007
    Location
    Gilbert, AZ
    Posts
    1,381
    Sorry for your loss

    On the bright side if it's only the hull that is damaged and everything else is fine you can pick a new replacement for $120

    http://cgi.ebay.com/Traxxas-Spartan-...ht_2032wt_1030

    At least you dont have to buy a whole new boat

  9. #9
    RC Competitor
    Join Date
    Jan 2011
    Posts
    60
    I had the same exact thing happen to my slash 4x4 that is water proof. it was caused by moisture inside the receiver box.

  10. #10
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    Thanks guys! I'm going to call Traxxas asap to see what they say about it. As far as I know the only damage is to the hull but I'm not sure I would feel confident using that receiver again. Time will tell. Here are the pics;




  11. #11
    RC Qualifier
    Join Date
    Dec 2010
    Location
    Canada
    Posts
    531
    Heck, a little scotch tape and some TLC and you will up and running in no time.

    That is quite a mess, it will be interesting to hear what Traxxas has to say.

    Kevin

  12. #12
    RC Qualifier
    Join Date
    Nov 2006
    Posts
    532
    Nice Plymouth in the background, Im sure traxxas will help....GOODLUCK!!!

  13. #13
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    It's going in to be looked at The owner of Maximus(LHS) I go to had a call tag sent to him so I wouldn't have to pay for the shipping Customer Service at Traxxas was great!! Jason e-mailed me all the information needed to return it and even called the owner of Maximus to follow up on everything Thanks Jason!!
    I'll keep you posted on what they find. Until then, it's... beat'n on the Stampede.

  14. #14
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    IT'S BACK!!!! And with a new hull!! There must have been a problem with the radio because they replaced it with a new one. They also replaced the rudder, must not have liked my "hack job" I don't have a picture of the rudder yet but someone else had put up a picture of the one they received from Traxxas and mine is the same. It looks like the same size inlet hole but there's a small notch,(halfmoon shape)at the beginning of the inlet. They also put the stock water lines in from the rudder to the ESC and from the jacket to the outlet but left the larger 1/8th hose I installed that passes water from the left to the right side of the ESC and from the ESC to the jacket. I hope this will still be enough to cool everything with the 3s lipos I'm using? I have to adjust the rudder,bolts are lose, and the prop shaft, agled down too much and then it should be ready for a test run I'm waiting for the frost to lift here at work so that I can get to one of the ponds on the golf course and see what I get for temps No camera today but I'll post my results later today
    A big THANK YOU!! to the Traxxas employees that helped me out! Never thought this would be covered in full and because my LHS( Maximus-Kittery,Me) helped out, the shipping was on Traxxas as well. Awesome customer support
    Now lets see if this boat can do what they claim it can

  15. #15
    RC Qualifier
    Join Date
    Jul 2010
    Posts
    293
    Nice carnage! Glad you can repair it. Traxxas customer service is awesome
    That Plymouth in the background is incredible!
    Last edited by DKO; 04-16-2011 at 09:06 AM.

  16. #16
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    Thanks DKO, the customer service dept. is great and has always been to me. I didn't get a chance to test out the boat.... I had to program the radio, set up the boat and the weather wasn't the best, very windy and cold and rain is on the way plus it's the weekend, family time.... I need two more boats

    Here's a picture of that Plymouth Cuda on my 2" extended VXL Stampede. It's from Zielkeracing.



    All seems to be working well. I put some more of the larger cooling lines back on and ran it today with temps @108 for the motor and @78 for the ESC. I ran it three different times,checking temps inbetween each run and they were all around 3.5 minutes with no thermal shutdown The temps on the motor start to rise after you stop and no water is being supplied to the motor.... I think the running temp is around 80-85 for the motor.

    Last edited by cooleocool; 04-21-2011 at 07:08 PM. Reason: merge

  17. #17
    RC Competitor
    Join Date
    Mar 2011
    Location
    New Jersey
    Posts
    70
    Same thing happened to me Champy!!! i was cruising around the pond and all of a sudden i opened it up and couldnt steer or get the throttle to back down and it came inland full speed and wacked a garbage can lol luckily i only bend a turn fin and needed a new prop sorry to see you damaged your hull have you figured out why this happened?

  18. #18
    RC Racer
    Join Date
    Jul 2010
    Posts
    182
    I'm guessing it was the radio because they gave me a new one. Is yours running OK after your loss of control ?

  19. #19
    RC Turnbuckle Jr.
    Join Date
    Nov 2006
    Location
    USA
    Posts
    3,138
    I hear these radios have a random bind problem??
    First MiniSlash
    HK6XL Revo 4s 60mph Amsoil dealer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •