Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Apr 2011
    Posts
    2

    Unhappy ESC won't stay on: Green, red, red, off

    I have the E-Revo 1/16 VXL with the 3m, all stock. The ESC won't stay on for more than a few seconds now. It turns green, then blinks red slowly twice, then turns off. I've tried it with 4 different, fully charged batteries with the same effect. Sometimes I can get it to stay on, but only the steering works.

    Any idea what that sequence means or suggestions for how to fix it?

  2. #2
    RC Champion
    Join Date
    Mar 2011
    Posts
    2,334
    The manual says that that pattern means that it is binding with the transmitter.

    Check that your connections from the ESC to the motor are correct.

    Make sure that the batteries in the transmitter are not dead or dying.

    What does the transmitter do when this happens?
    Last edited by E-RevoVXL; 04-17-2011 at 05:37 PM.

  3. #3
    RC poster
    Join Date
    Apr 2011
    Posts
    2
    Thanks for the quick reply. Batteries in the Tx are fine (tested each). I even re-calibrated the throttle and the ESC took it just fine. I had it in LiPo mode, when I switched to NiMH I was able to get it to stay on. I can steer, but the throttle won't even budge the motor. I've tried disconnecting and reconnecting the motor, the connections seem fine. Spinning the wheels turns both the gears and the motor freely and without noise.

    Unfortunately I don't have another motor to test, any thoughts?

  4. #4
    RC Champion
    Join Date
    Mar 2011
    Posts
    2,334
    Call Traxxas at 1-888-TRAXXAS.

    They should be able to help you; if not, they can send you a new ESC.

  5. #5
    RC poster
    Join Date
    Apr 2015
    Posts
    8
    Did you ever find out the problem? Mine does the same thing!

  6. #6
    RC Qualifier
    Join Date
    Jun 2016
    Location
    Las Vegas, NV
    Posts
    388
    Awesome Job searching JT, I am sure they got it figured it. Probably had to replace the ESC.
    Slash Ultimate, HW XR8 SCT Pro/3660 SD-G2 4300 KV

  7. #7
    RC Enthusiast
    Join Date
    Nov 2016
    Posts
    30
    Sounds similar to my ESC problem too. The ESC light would flicker and blink randomly (and the motor would not run properly), and eventually blinked into nothing. The steering still worked, but no throttle. So power is going through the ESC just not how its supposed to.
    I have ordered a new ESC and I will try update here if I find that was the problem.
    I wish there was a solid thread to troubleshoot ESCs, check out mine if you like I am learning as I go and hoping to help others like me with ESC issues and beginners upgrades.

    Edit: Add on- once mine blinked out it would not come back on. The receiver light still does.
    Last edited by 250Greenmachine; 11-15-2016 at 06:20 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •