Hello dear citizens of this forum. My friend purchased new Nitro Rustler kit.

Several days later he complained that both channels (steering and throttle) work vice versa. We downloaded the manual (transmitter #2238) and tried to adjust it. The result was unexpected and unwanted: the servos stopped to respond.

We moved left-right / front-back, however servos don't respond at all. And we notice that transmitter and receiver are still linked (both leds are still green). Anyway we tried to re-bind it successfully, but nothing. We reset the transmitter a lot of times (according to nitro rustler profile). As well we tried to reset and re-adjust end points, to lock unlock knobs and model.

The only strange thing is steering trim switch is able to cause front wheels to move, while Multi-Function knob is "dead".

Please advise what can be the reason for failure. I remind that it happened as result of transmitter set-up. All wiring and antenna look perfect, no damage. As well batteries re-charged several times.

Best regards, Eduard.