Results 1 to 11 of 11

Thread: Battery Trouble

  1. #1
    RC poster
    Join Date
    Jan 2012
    Posts
    17

    Battery Trouble

    I have a Traxxas 2s lipo 10,000Mah I'm running in a Stampede vxl 4wd, charging with a Primal 4amp lipo charger w/ built in balancer; all bought new less then 2 weeks ago, 1st couple of runs got maybe 45mins run time but the last couple charges I'm only getting 8-10mins. After the 1st short run time I looked over all the wheels and pulled out some string rapped around axle (thought OK problem solved) but this morning the esc light turned red after 8mins again. I'm charging my Traxxas 2s 5800Mah as I type to see if it does any better.

    Any thoughts would be greatly appreciated

  2. #2
    RC Champion
    Join Date
    Aug 2010
    Location
    Inver Grove Heights, MN
    Posts
    1,540
    Do you use Low Voltage Cut-off?
    So I taped my hamster to the Pede..

  3. #3
    RC poster
    Join Date
    Jan 2012
    Posts
    17
    Yes the LED shines green when turned on (according to the manual, red for NiMH, green for Lipo) but after 8-10mins it flashes red and the truck becomes very slow. Its a stock stampede vxl 4wd. Do Lipo's get a "memory"?

    My other battery is almost charged, as soon as its done I'm going to try it to see if its the truck or battery.

  4. #4
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Okanagan Valley B.C.
    Posts
    760
    Quote Originally Posted by 3 MEN AND A BOAT View Post
    Yes the LED shines green when turned on (according to the manual, red for NiMH, green for Lipo) but after 8-10mins it flashes red and the truck becomes very slow. Its a stock stampede vxl 4wd. Do Lipo's get a "memory"?

    My other battery is almost charged, as soon as its done I'm going to try it to see if its the truck or battery.
    Could be the thermal protection. Are you running a cooling fan on your esc and a heatsink on the motor?

    http://www.youtube.com/watch?v=QL7Wn6MJcpo

    Fast blinking is thermal protection and slow blinking is low voltage.
    Last edited by NITR0 newbie; 01-08-2012 at 01:17 PM.
    O.S.21 Nitro Revo, Stampede 4x4, 2 Axial Honcho's

  5. #5
    RC poster
    Join Date
    Jan 2012
    Posts
    17
    just finished running the 5800Mah which lasted about 25mins

    Quote Originally Posted by NITR0 newbie View Post
    Could be the thermal protection. Are you running a cooling fan on your esc and a heatsink on the motor?

    http://www.youtube.com/watch?v=QL7Wn6MJcpo

    Fast blinking is thermal protection and slow blinking is low voltage.
    No fans or upgrades at all. If its a heating issue I should be able to let it cool down and try the battery again, correct.

    I tried it real quick it blinks slow I'd say at 1 second intervals.
    Last edited by cooleocool; 01-08-2012 at 10:50 PM. Reason: post merge

  6. #6
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Okanagan Valley B.C.
    Posts
    760
    Sounds like it must be the batteries but then again I'm new to the electric thing so to be honest I'm not sure what yer problem may be. Good luck though.

    Just another though is that you could check your batteries with a multi-meter as well just to confirm the voltage on a fresh charge. . . .
    O.S.21 Nitro Revo, Stampede 4x4, 2 Axial Honcho's

  7. #7
    RC Enthusiast
    Join Date
    May 2011
    Location
    Phoenix
    Posts
    37
    When you charge the pack does your charger tell you how many mah is put into the pack?

    Sent from my Nexus S using Tapatalk

  8. #8
    RC Enthusiast
    Join Date
    Jan 2012
    Posts
    43
    do you have a battery checker to see if all the cell are charged

    my first 3s lipo i had a blown cell so it wont charge to 4.2v so after 5-10min the car would go in protection mode

  9. #9
    RC poster
    Join Date
    Jan 2012
    Posts
    17
    guess I'll have to buy a multi-meter

  10. #10
    RC Competitor
    Join Date
    Jan 2011
    Posts
    87
    They make a nifty lil tool i keep in my box for checking lipo voltage. Think its called a cell spy? Has a lil digital read out, you just plug it into the balance port and it will give you each cell as well as total. Good thing to keep with you at all times. Even after coming off the charger i check the cells to make sure of consistency and full charge.

  11. #11
    RC poster
    Join Date
    Jan 2012
    Posts
    17
    I took it to the hobbyshop, they checked it and said it has a bad cell. I'll call Traxxas tommorrow.

    thanks for everyones help,
    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •