Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Apr 2012

    Steering servos won't initialize with other RXs, any thoughts?

    So I bought a summit as my second ground RC unit, finally getting away from planes and helis. Much less stressful to drive than fly :P I'm having a pretty major problem with the steering servos though (2075 servos, stock summit, etc). On the stock (TQi 2.4Ghz) rx, the servos work fine. As soon as I power the RX (either with the ESC on the truck or a separate BEC) the servos buzz a little to center, then go quiet until I tell them to turn (which they will do). More over, they ALWAYS work, just as you would expect. On every other RX I own they usually won't turn on. They don't center, buzz, or respond to my controls.

    Once every 20 or so power cycles one servo will turn on, 5-10 seconds after everything else has powered up. Once powered up it will continue working until I power off.

    I have tried the following RXs:

    Hitec 27Mhz FM 5 Channel
    Servo Tester (Not exactly a RX)
    Unknown FM RXs x3 courtesy of my local club's members.

    Each of these RX's works with every other servo I have ever plugged into them.

    I have tried the following:

    Different channels on each of the RXs.
    One steering servo connected, or both using a Y (Or both plugged directly into the AR500 as it has dual Aileron output)
    Other servos connected, or just ESC
    Nothing but BEC and a steering servo connected
    Checked for reversed wires/connections (As they sometimes power up and work, this is not it)
    Checked voltage - 5.97v making it to the servo according to my multimeter

    I can't find anyone else with even a remotely similar problem on google or this forum, unfortunately. Traxxas support says the servos are just standard servos, and they have never heard of anything like this before. I really don't want to have to go buy another set of servos/single high power servo for $100, as i don't have the money now and the servos on there work great (when connected to the TQi RX). Has anyone had a similar problem, or does anyone have any idea what to try?

  2. #2
    RC poster
    Join Date
    Apr 2012
    Doesn't seem like anyone, anywhere has any idea why this would happen Asked at a few hobby stores yesterday too.

    I did figure out a work around though. It seems like, on non-traxxas rxs, they will only initialize when they are warm! So if I heat them using an air heat gun, or if I run them until they warm on the traxxas rx then quickly switch them they will turn on every time. But as soon as they cool, they stop turning on.

    Oh well, at least they stay on once then are on.

  3. #3
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Alma, Michigan
    That is... weird. lol
    Makes me wonder if it is a water issue... or bad contacts??
    Whatever it is I just typed... could be wrong.

  4. #4
    RC poster
    Join Date
    Apr 2012
    It is weird :/

    They have never seen water, or really even much dampness, but it could be.

    Bad contacts was my first thought. I think I have ruled it out by using a servo extension, and having it still display the same behavior. Could be a bad contact further down the line or in the servo, but I still wouldn't get why the traxxas one would always work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts