Results 1 to 2 of 2
  1. #1
    RC Racer
    Join Date
    May 2007
    Winnipeg, Manitoba, Canada

    Problem with TQi radio

    I just got a brand new slash 4x4 and today my first chance to really run it.

    I went out to a favorite bashing spot with some fully charged batteries ready for some fun. I hit it he throttle and the tuck took off, got about 30ft away and stopped. I couldn't get it to respond at all. No throttle or steering response. I walked toward the truck and once I was about 15 or so feet away it started responding I again. I tried it a few more time and same thing happened at approximately the same distance with the same results.

    My first thought was the batterys in the controller (rechargeables) were dying but I put them in the traxxas link controller I have for the Revo and I was easily over 100 ft away and it worked fine. This leads me to believe that I have something wrong with my controller. Any ideas before I contact traxxas for warranty?

    "obey gravity. It's the Law."

  2. #2
    RC Competitor
    Join Date
    Mar 2012
    Melbourne, Aust.
    Have you tried the radio with some good alkaline batteries? If you have a docking station, make sure its not charging the phone, incase thats taking power.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts