Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Dec 2012

    Summit steering issue.

    I have a Summit that is less than a month old. My son and I have only had it in mud one time. Ever since, the steering is very sluggish. The steering servos seem to work fine when linkage disconnected, but very stiff when linkage reconnected. It has a slight turn left but none to thr right. I can turn the front wheels manually and really don't feel any binding. Have I damaged the vehicle already????

  2. #2
    RC Turnbuckle Jr. Cameron's Avatar
    Join Date
    May 2009
    Edmonton, Alberta
    if you disconnect the horns and turn the truck on, do both servos center out and then turn left and right and then return to center when you turn the wheel back and forth and then let go on the radio?

    This is a great video showing how to center and align the servos if they are out of alignment.

    *** better yet, just undo the toe-links from the axle carriers, that way you can check all this by only removing 2 screws
    Last edited by Cameron; 12-25-2012 at 03:11 PM.
    (RAH) (AH) + [ROMA (1+MA)] + (GA) + (OOH)(LA)

  3. #3
    RC Competitor
    Join Date
    Oct 2012
    Perth, Western Australia
    Ive just had a 2075 steering servo go on my three week old Summit. Mind you, it should have died sooner given the treatment it's had in that time.
    Yes, I did adjust servos at the get go to prevent them fighting each other, which they did out of the box.

    How I determined the fault was as follows:

    The car wouldn't respond and the lights were very dim pulsating with a steering input.
    The ESC was flashing green and got hot quickly
    ESC BEC voltage was measured at 6.02v at the Rx
    I pulled out one of the steering servos from the Rx and the steering still wouldn't work
    disconnect the steering and the one connected servo worked fine
    tried moving steering servos by hand with power off and one was extremely stiff and the other felt normal
    Put power back on to the one good servo (bad one removed from car) and steering works fine.

    Not sure what's happened inside the dead servo as all the gears are OK and the binding still exists when all the gears are removed. I tried contact cleaner but no difference. I couldn't get the circuit board/motor out of the servo case either. Yes, I did remove the two small screws that screw in to the motor.

    Anyway, 500oz/in Savox 1230 is on it's way for a single servo install
    Summit 11/68T 4S 2000kV
    E-Revo 14/56T 6S 2200kV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts