Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jan 2013

    Throttle stopped working

    My revo 3.3 is fairly new. Only 2-3 hours on it, no hard hits, hasn't run through standing water, has gone on snow.
    Was running it today and the throttle went wot on its own for a couple of seconds. Ran fine after until i'd give it some and nothing would happen. Right away i let off and tried again and the servo would move. Eventually it gave out completely.
    I just turned on the rec/trans and tried again and the throttle still isnt doing anything. I went through the optidrive reprogramming and couldnt get the optidrive light to flash while holding the set button. All the lights are green, steering works, cant get it to go between fwd/rev, battery in the truck was just charged, remote isnt flickering red... What am i dealing with?

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Unplug the Opti-Drive and plug the throttle servo directly into the channel 2 port. Does it work? If yes then the OD system failed. If not, plug the steering servo into channel 2 and see if it still works when pulling the throttle trigger. Also plug the throttleservo into channel 1 and see if it moves when twisting the steering wheel. Does the problem follow the servo or not?
    The Super Derecho

  3. #3
    RC Qualifier
    Join Date
    Dec 2011
    Okanagan Valley B.C.
    Unless you really NEED reverse I'd recommend the FOC and ditch the opti drive
    O.S.21 Nitro Revo, Stampede 4x4, 2 Axial Honcho's

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts