Results 1 to 5 of 5
  1. #1
    RC Qualifier
    Join Date
    May 2013
    Posts
    352

    Slipping or chattering power at high rpm

    Today I changed my center driveshaft and put everything back together. I noticed that if I pull the throttle half way then all the way, the truck starts to make a chattering power noise (not grinding). Like it's slipping. Sorta like when you rev a motorcycle up and at the high end of the RPM it starts to chatter. I was thinking that I may need to tighted the slipper clutch. Haven't yet. But thought I would ask you all here to see what the issue may be. Any ideas?

  2. #2
    RC Competitor
    Join Date
    Mar 2013
    Location
    Colorado
    Posts
    63
    could be your gear mesh also.

  3. #3
    RC Qualifier
    Join Date
    May 2013
    Posts
    352
    I just fixed that and it's good now. Thanks for suggesting that. I think all my gearing is right but still having the same issue. I'm thinking the issue may be the VSC now. Any idea on the life span of these?

  4. #4
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    15,607
    What battery motor and esc?
    Ya can't polish fertilizer...

  5. #5
    RC Qualifier
    Join Date
    May 2013
    Posts
    352
    Battery: lipo 3s 5000.
    Motor : standard on the stampede brushless VXL
    SC: standard in brushless VXL

    I noticed that if I put the SC in beginner mode that it doesn't make the slipping noise. Only in the regular mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •