Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Dec 2013

    Jato 3.3, No power?


    I finally after several years dusted off my Jato truck. I checked the batteries and put in some new ones and I noticed that the servos gets no power. Anyone that have faced the same problem? I cant even hear the servos turning on when i switch the ON button. Maybe the reciever is dead? Any suggestions? Its the 27mhz model. I tried to change the wire set up to the reciever sill no luck. I also know from the past that the antenna wire is ripped. But it worked anyway the last time i started the truck.

    Sorry for my bad english and Im thankful for any help!

  2. #2
    RC Qualifier
    Join Date
    Mar 2011
    Denver Colorado
    Rebind the radio to the receiver, make sure that you have the batts in correctly in the truck. I have a bunch of those 27mhz receivers laying around. I could ship you one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts