Results 1 to 11 of 11

Thread: Steering issue

  1. #1
    RC Racer
    Join Date
    Mar 2013
    Location
    Connecticut
    Posts
    178

    Steering issue

    Hey guys it's been a while. Hope everyone is doing good. So I took out my 2wd slash the other day after a few month hibernation. Cleaned it all up charged the battery and when I turned it on the front wheels were jittery and going crazy. Everything was fine when I put it away. Any thoughts??
    Traxxas 2wd raptor svt

  2. #2
    RC Racer
    Join Date
    Jun 2013
    Location
    Southern Alberta
    Posts
    192
    If water got in it, the rheostat could be going bad.

  3. #3
    RC Champion
    Join Date
    May 2011
    Location
    Biloxi, MS
    Posts
    1,549
    Did throttle work? Any other rx input working? 2.4ghz? sounds like interference?
    Merv, Sl4sh, P4de, Embe, Slash
    2400/2200/4000kv

  4. #4
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Lansing, Mi
    Posts
    373
    Does it look like this?



    If so... Traxxas support helped me fix the problem.

    Call support, Ask for Ian.
    My wife hates it but I love It.

  5. #5
    RC Racer
    Join Date
    Mar 2013
    Location
    Connecticut
    Posts
    178
    Throttle worked fine it is 2.4. It's similar to the video but more erratic.
    Traxxas 2wd raptor svt

  6. #6
    RC Champion
    Join Date
    May 2011
    Location
    Biloxi, MS
    Posts
    1,549
    Prolly a bad servo
    Merv, Sl4sh, P4de, Embe, Slash
    2400/2200/4000kv

  7. #7
    RC Racer
    Join Date
    Mar 2013
    Location
    Connecticut
    Posts
    178
    Awesome. Guess it will have to wait. I don't have the money to fix it.
    Traxxas 2wd raptor svt

  8. #8
    RC Racer
    Join Date
    Jun 2013
    Location
    Southern Alberta
    Posts
    192
    if u have another rc, try the servo on that radio.

  9. #9
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Lansing, Mi
    Posts
    373
    Just call Ian at Traxxas support he fixed it. It took 10 minutes at most. I tried another servo with the same results.
    My wife hates it but I love It.

  10. #10
    Traxxas Employee
    Join Date
    Oct 2012
    Location
    Lewisville, TX
    Posts
    30
    The first thing I would try doing is to re-center out the servo. To do this, uninstall the steering linkage from the servo (just take out the screw on the bottom and pop the servo saver off), turn on the transmitter, turn on the vehicle. If this is going to fix the issue, then it will center itself out and not shake. If that is the case, reinstall the linkage with both wheels parallel and facing forward. If this does not fix the issue, then the issue will either be with the server itself or with the radio.
    Hope this helps! If you need anymore help give us a call at 1-888-Traxxas (872-9927), or outside the US at 972 265 8000.

  11. #11
    RC Racer
    Join Date
    Mar 2013
    Location
    Connecticut
    Posts
    178
    Thanks guys very much
    Traxxas 2wd raptor svt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •