Results 1 to 12 of 12
  1. #1
    RC Competitor
    Join Date
    Jan 2014
    Location
    Gilbert arizona
    Posts
    93

    Slash 4x4 Steering Problem

    I'm having a issue with my steering. If I put the steering trim on the transmitter 0. It pulls really bad to the right and if I go all the way left it goes straight for a bit then starts pulling left. Is there any way to fix this.

  2. #2
    RC Qualifier
    Join Date
    Oct 2013
    Posts
    511
    Something might be binding in the steering system causing it to stick one way or another or it could be the servo has just had it and u need one.


    Just my 2 cents

  3. #3
    RC Competitor
    Join Date
    Jan 2014
    Location
    Gilbert arizona
    Posts
    93
    the wheels are straight when it is all the way to the left it just goes straight then gradually starts pulling to the left

  4. #4
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis
    Posts
    14,172
    You might want to try moving the linkage from the steering servo over a tooth. This might be a quick and easy fix for you. I have had it happen a few times and it can be readjusted back straight.
    Member of the 10,000 + posts club! Here to help!

  5. #5
    RC Competitor
    Join Date
    Jan 2014
    Location
    Gilbert arizona
    Posts
    93
    Quote Originally Posted by El Sob View Post
    You might want to try moving the linkage from the steering servo over a tooth. This might be a quick and easy fix for you. I have had it happen a few times and it can be readjusted back straight.
    I will try it

  6. #6
    RC Qualifier
    Join Date
    Dec 2012
    Posts
    368
    I just went through this with mine. I went into the menu tree to adjust the sub trim and the servo must self center when you go to this. I set my knobs at zero and pulled the horn off the servo and set my wheels straight and put it back on. It's straight now and my end points after I did this are perfect from side to side. Before it turned farther in one direction.
    Ultimate Slash 4x4, HCG Slash 4x4, Ruckus 2wd

  7. #7
    RC Competitor
    Join Date
    Jan 2014
    Location
    Gilbert arizona
    Posts
    93
    So I bought a new servo (savox sc-0252mg) worked a bit better but its pulling right my lhs said that my heim joints are tight they put oil on them and it is helping more but its not reseting back to center when I turn right I have to keep recorrecting it any ideas of what I can do

  8. #8
    RC Qualifier RiderZ's Avatar
    Join Date
    May 2006
    Location
    Planet Earth
    Posts
    419
    Something has to be binding in the steering assembly.I would take it apart and do a little investigating.

  9. #9
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis
    Posts
    14,172
    You might want to give thought to getting the STRC steering bell crank set. That will eliminate a lot of the parts that can fail on your truck. Every truck I have put it on has had improved steering.
    Member of the 10,000 + posts club! Here to help!

  10. #10
    RC Racer
    Join Date
    Sep 2013
    Location
    Does it matter?
    Posts
    230
    The slash 4x4 has pretty crappy alignment..keep messing with the steering trim, you'll eventually find something that is decent but not perfect.

  11. #11
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis
    Posts
    14,172
    Quote Originally Posted by russkiy View Post
    The slash 4x4 has pretty crappy alignment..keep messing with the steering trim, you'll eventually find something that is decent but not perfect.
    I think that's due to all the plastic parts on the steering. If you bump something or hit a big dip is all you need to throw the steering off.
    Member of the 10,000 + posts club! Here to help!

  12. #12
    RC Champion
    Join Date
    Dec 2012
    Location
    Norfolk, va
    Posts
    1,164
    Undo the servo and make sure your wheels turn freely, there should be no binding at all. If there is binding, find out what it is and fix it.

    I run the stock bellcrank on all my slashes and haven't had any tracking issues, cars run straight and go straight when I let go of the steering wheel.
    We were big into the slash 4x4's last year, I had 6 and my brother had 1, I currently have 1 and my brother has 3. My last ultimate lcg is for sale. I switched to losi and associated.
    Last edited by Zepher; 02-09-2014 at 10:00 AM.
    ERBE, ERBE, Summit, Slash 4X4, Bandit,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •