Results 1 to 13 of 13
  1. #1
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59

    LVD Kicking In Too Soon???

    Just as it says. I think the LVD kicks in too soon. I am getting 9 minutes run time on Traxxas 5000mah 7.4v packs and then it kicks into LVD mode. When I check the batteries all cells are at 3.8v. Is this normal?

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,314
    What is the temp outside?
    How many times have you used the packs?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    Outside temp was around 25. I have run these packs 3 times since they were new. I am charging them on a Traxxas EZ Peak Plus 6am with dual pack adapter.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,314
    25F I am guessing?

    If so, it is possible that a few things are attributing to your issue.... cold and new packs. It usually takes a few cycles to get full performance out of a pack and cold temps lower C rating which can force voltage to dip during use and cause early LVD.
    Whatever it is I just typed... could be wrong.

  5. #5
    RC poster
    Join Date
    Feb 2014
    Posts
    1
    Not to steal his post but I have the same issue
    Truck is a new 3903

    5800mah 25c lipo getting 10 to 15 mins a run. Getting more run time with the stock nimh. All packs have about 10 runs on them. Got more lipos coming for testing.

    I am using a traxxas charger But it has been cold here in pa. So the temp may be the issue? The packs are not hot or cold after a run there about room temp from what I can feel no way to check oh.
    Last edited by Dadx2mj; 02-19-2014 at 06:12 PM.

  6. #6
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    Yeah its funny, I am only putting 2600mah back into the packs. I called Traxxas and they said the cold is more than likely the problem/the packs need to break in a bit. I guess we will just have to see what happens this spring when it warms up. I am happy though with the power/speed of the truck over the NiMh packs I was running though. The 3903 is a BEAST with lipos and a single 775 Titan conversion, I am running 68/20 gearing and it rips!

  7. #7
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,314
    I'm guessing voltage is around 3.8v/cell after your run... which means you are only using about half of the juice that will be available once it warms up.
    Whatever it is I just typed... could be wrong.

  8. #8
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    Yeah kinda bummed the LVD kicks in that high, but atleast it's not kicking in too low and hurting the packs. Maybe I should just get the MMM2 and be done with it.

  9. #9
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,314
    That is not going to help you any... the packs are still going to dip and trigger LVC early.
    Whatever it is I just typed... could be wrong.

  10. #10
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    I want more run time so I ordered some SPC 8200mah batteries, should be here early next week. I am going to mod the Emaxx a little and use the velcro straps from an AE RC8E to hold them into the battery boxes since they are too tall (27.5mm tall vs 25mm for TRX 5000mah) for the factory hold downs.

  11. #11
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,314
    Would part number 3927X work?
    Whatever it is I just typed... could be wrong.

  12. #12
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    LOL Funny you should mention those. I was digging through my spares box for a new front skid and guess what I found? I didnt even realize I had them. I bought a grab bag of E-Maxx parts on Ebay last fall and they were in there. Guess no velcro straps for me. :-D

  13. #13
    RC Competitor
    Join Date
    Feb 2011
    Location
    Wellsburg, IA
    Posts
    59
    Well, I just got done running the E-Maxx with the SPC 8200mah batteries and wow! I couldnt believe the run time I got. 23 minutes!!! Which is great but brings the question up to why going up 3200mah on the batteries would add that much more? I was getting 9 minutes with the Traxxas 5000mah packs.
    They are recharging now, we will see how many MAH goes into them. When the LVD kicked in this time I checked them and they were at 3.7 per cell.
    EMaxx 3903 / Revo 3.3 5309 / Slash 2wd 58034

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •