Results 1 to 9 of 9
  1. #1
    RC Racer
    Join Date
    May 2014
    Location
    NJ USA
    Posts
    112

    First issue with my Rally

    Ok actually 2 issues...

    I'm using a traxxas LIPO 3s 8000 mah in my rally. After maybe 20 mins or so, full power gets cut and when I take the cover off I see the vxl3s is slowly blinking red.

    2nd issue happened around same time with steering. If I accelerate without steering, it will turn on its own. But if I use remote I can turn it straight.

    I was continuously spinning out for fun but would think it would be made to handle that.

    Any suggestions? Hopefully nothing bad....

  2. #2
    RC Qualifier
    Join Date
    Feb 2014
    Posts
    457
    Running the vxl for 20 minutes on 3s is going to be pretty tough on it, slow red is low voltage, but i'm sure the esc and motor is very hot by that point. You should be able to adjust the steering trim right from the remote, if that's not enough just remove the servo horn and re center it.

  3. #3
    RC Racer
    Join Date
    Feb 2014
    Location
    Australia
    Posts
    165
    Slow blinking red is low voltage detection, fast blink is thermal shutdown.

  4. #4
    RC Champion soundmaster's Avatar
    Join Date
    Jan 2012
    Posts
    2,858
    Quote Originally Posted by MrGrim999 View Post
    Ok actually 2 issues...

    I'm using a traxxas LIPO 3s 8000 mah in my rally. After maybe 20 mins or so, full power gets cut and when I take the cover off I see the vxl3s is slowly blinking red.

    2nd issue happened around same time with steering. If I accelerate without steering, it will turn on its own. But if I use remote I can turn it straight.

    I was continuously spinning out for fun but would think it would be made to handle that.

    Any suggestions? Hopefully nothing bad....
    Both "issues" are normal behaviour

  5. #5
    RC Racer
    Join Date
    May 2014
    Location
    NJ USA
    Posts
    112
    So no one thinks I broke anything huh??

  6. #6
    RC Champion soundmaster's Avatar
    Join Date
    Jan 2012
    Posts
    2,858
    Quote Originally Posted by MrGrim999 View Post
    So no one thinks I broke anything huh??
    No. I think the esc goes into termal shutdown. Check the temps on esc and motor and get a fan for the esc and heat sink + fan for the motor if you want to stay on 3s, otherwise those parts will melt down like butter in the sun

    If you accelerate hard it is also normal that the car will pull away into either direction and you have to countersteer.

  7. #7
    RC Racer
    Join Date
    May 2014
    Location
    NJ USA
    Posts
    112
    I can understand the esc but it turns pretty hard when I give it throttle. I'm being hopeful I didn't break anything because I don't see any damage and if I over compensate using the remote i can get it to go straight....

  8. #8
    RC Champion soundmaster's Avatar
    Join Date
    Jan 2012
    Posts
    2,858
    Remove the motor and check the hole drivetrain for binding.

    Check the diffs, drive shafts, bearing, loose tires, rounded hexes...

    Also check the steering for binding with servo detached.

  9. #9
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    6,369
    Does is run straight when you're coasting? How about when you accelerate slowly?
    My Black & Blue Rally is faster than your color...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •