Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Nov 2011
    Location
    Nashville
    Posts
    15

    Trim always needs adjusting

    I have a 1/16 rally. It is pretty much all stock and almost new. The problem I have is when I adjust the trim, a few seconds later I have to do it again. Sometimes from full left all the way right and sometimes it wont even go straight then. Any ideas?

  2. #2
    RC Qualifier
    Join Date
    May 2011
    Location
    Virginia
    Posts
    320
    I would go to your manual and find out how to reset the trim to zero and set up your steering links to center the wheels best you can by eyeballing them. Then see if there is an improvement
    2wd Slash VXL
    3906 MMM

  3. #3
    RC poster
    Join Date
    Nov 2011
    Location
    Nashville
    Posts
    15
    I have. It is centered perfectly when I turn it on after doing that. Then it is all over the place again. It's really weird (and irritating).

  4. #4
    RC Qualifier
    Join Date
    May 2011
    Location
    Virginia
    Posts
    320
    I'm not sure. Perhaps your transmitter is acting up. Do you have another you can bind to your car to test?
    2wd Slash VXL
    3906 MMM

  5. #5
    RC Turnbuckle Jr. Petertje60's Avatar
    Join Date
    Jan 2011
    Location
    Rotterdam, Netherlands
    Posts
    8,622
    Maybe you stripped the servo horn.
    Nobody is born with experience

  6. #6
    RC poster
    Join Date
    Nov 2011
    Location
    Nashville
    Posts
    15
    Traxxas says it may be the servo saver. So, I ordered one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •