Results 1 to 7 of 7

Thread: Power issues

  1. #1
    RC poster
    Join Date
    Dec 2014
    Posts
    5

    Power issues

    Hi guys,

    I just bought my Alias two days ago and am new to quads. Have a Traxxas Revo which helped me decide to get the Alias because they are such a great company.

    Anyway, the new Alias flies really great but the battery is showing empty really fast on the control. Then the copter keeps dying in mid flight and falling down. The LED is flashing at this point. There is no beeping from the controller to warn of low power while flying. I turn the controller off and back on again. The flashing blue LED goes solid again and I can engage and fly some more. It will fly for 2 or 3 minutes more and then it will fall again and the LED starts flashing again.

    Basically, I am getting a full 9 or 10 minutes of flight time out of the battery with very gentle flying, but I have to reset it approximately 6-8 times with increasing frequency towards the end. The controller only beeps with the low power warning right at the very end before the battery is actually dead.

    Does this sound like a bad battery pack or could it be something else? Any suggestions are appreciated. Just to reiterate. I absolutely love this copter and this small glitch won't change my mind about it

  2. #2
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525
    Something is wrong with the battery or the electronics board. Not sure which.
    Alt-248 on the number pad =

  3. #3
    RC poster
    Join Date
    Dec 2014
    Posts
    5
    I'll go buy a new battery today and see if that fixes it. Is it typical to ask the Hobby shop for a replacement if it turns out to be the board or do I have to get support from Traxxas for that? I've only had it 4 days now.

  4. #4
    RC poster
    Join Date
    Dec 2014
    Posts
    5
    Ok, I went to my local hobby shop and picked up a new battery and this did not fix the problem. It seems like the controller is unbinding from the copter mid flight over and over. My hobby shop is ordering in a new board for it. Hopefully that fixes it.

  5. #5
    RC Qualifier
    Join Date
    Sep 2014
    Location
    SE Alaska
    Posts
    268
    That's good to hear that your hobby shop is helping you with the issue. Normally, they just tell you to contact the manufacturer directly if you run into problems. Did you try contacting Traxxas at all? If the copter is only four days old, I would imagine they'd repair or replace the entire thing free of charge if it's a defective board. Hope you get it fixed soon.

  6. #6
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525
    Quote Originally Posted by Mogg2112 View Post
    That's good to hear that your hobby shop is helping you with the issue. Normally, they just tell you to contact the manufacturer directly if you run into problems. Did you try contacting Traxxas at all? If the copter is only four days old, I would imagine they'd repair or replace the entire thing free of charge if it's a defective board. Hope you get it fixed soon.
    I agree, but he'd still have to pay the shipping to Traxxas.
    Alt-248 on the number pad =

  7. #7
    RC poster
    Join Date
    Dec 2014
    Posts
    5
    Nope, did not try to contact Traxxas about the issue. I'll wait and see if it gets resolved ok through the hobby shop. I think it'll be fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •