Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Jan 2015
    Posts
    13

    Traxxas T-maxx 2.5 engine revs in forward but doesn't move (reverse works)

    I've replaced the clutch and checked the transmission on the 4910 T-maxx 2.5 but the engine just revs in forward (or jerks forward before not moving again even while pushing the throttle). The truck works and moves in reverse without any issues. The spur gear hasn't shredded and all the rubber pellets are like new. What could be the problem? Check out my Youtube video here of the issue:
    https://www.youtube.com/watch?v=9AgJXOHaCZE

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,636
    Possibly stripped the forward gear.
    The Super Derecho

  3. #3
    RC poster
    Join Date
    Jan 2015
    Posts
    13
    Opened the transmission again and realized the metal strip on the forward gear assembly wasn't working (part 4997) - the strip should flick out when the wheel is spinning to engage with the bigger wheel (not sure what the part number of that is but it's black in colour and has holes in the middle) which turns the drive shaft. Another issue was the drive pin had snapped in half but you can't get the part by itself (part 4995 contains the pin). Hopefully, once the new parts arrive - it should be up and running again - will keep the thread up to date @Double G

  4. #4
    RC poster
    Join Date
    Jan 2015
    Posts
    13
    Issue fixed @Double G.. it was the metal strip on the forward gear and the broken metal pin causing the issue in the transmission

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •