Results 1 to 8 of 8
  1. #1
    RC Competitor
    Join Date
    May 2015
    Posts
    83

    Traxxas EZ Peak Plus - LiPo Problem

    I have an EZ Peak Plus 4amp charger and had no issues charging my Nihm batteries, traxxas brand and duratrax. I picked up two LiPos from my local shop yesterday...Reaction 7.4V 5000mAh 2S 30C LiPo Hard Case, the fellow at the shop tested the batteries before purchasing and said they were good....I'm not knowledgeable enough to remember/know what numbers he gave me....I seem to remember something about 7.8. I took them home and plugged one into the charger, balancer included. It read the same as the non traxxas nihm. I pressed the buttons to go into advanced mode. Selected LiPo, set to balanced charge and started it charging. It ran for close to, if not, two hours. I thought that was pretty wierd as the nihms charged up in 30-45 minutes, but just chalked it up to lipos taking longer, this is my first experience with them. After the fan shut off I ran over, anxious to see how the lipos powered up the stampede vxl. To my dismay, the second light from the bottom was on solid. I pulled out the directions and referenced the picture...that read that the charger had timed out without reaching the target voltage. I called my brother, who has been into RC cars for a long time and he said, plug the battery into the car and see what happens. I plugged it in, turned on the truck, turned on the low voltage detection and drove the truck. The truck ripped it up, very fun to drive, got probably 30-40 minutes drive time out of it, LVD turned red so we shut her down. I haven't charged it back up, but is that what the charger should have done? LiPos are a lot of money and I just don't want to ruin anything!

  2. #2
    RC Qualifier Panamon Creel's Avatar
    Join Date
    Oct 2014
    Location
    Central Mexico
    Posts
    427
    Ez Peak Plus ID or non ID? even better the Traxxas # of the charger?

  3. #3
    RC Competitor
    Join Date
    May 2015
    Posts
    83
    ID, Model# 2970

  4. #4
    RC Competitor
    Join Date
    May 2015
    Posts
    83
    Just found this post:

    https://traxxas.com/forums/showthrea...r-for-my-Slash

    Going to take a look at it again when I get home! Sounds like this might be the problem I had, I didn't change the charge rate.

  5. #5
    RC Qualifier Panamon Creel's Avatar
    Join Date
    Oct 2014
    Location
    Central Mexico
    Posts
    427
    That would have been my next question, what charge amperage had you been using

  6. #6
    RC Competitor
    Join Date
    May 2015
    Posts
    83
    Whatever it defaults to....which I think was 1 amp, lol! Is it safe to go up to 3 or 4?

  7. #7
    RC Qualifier Panamon Creel's Avatar
    Join Date
    Oct 2014
    Location
    Central Mexico
    Posts
    427
    it's safe to go up to 1C which in the case of your 5000mAh battery would be 5 Amps so you can use the highest 4A of your charger without problems.

  8. #8
    RC Competitor
    Join Date
    May 2015
    Posts
    83
    Set to 4amps for charging after work and it all worked out, thanks for the help guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •