Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Oct 2015
    Posts
    1

    Brushless 1/16th ken block

    Hi everyone help needed please
    I bought a brushless ken block fiesta (model 7309) second hand , the car does not look like it's done much work ,so put new battery's in it and turned handset and car on and without pressing trigger the car just shoots off , so followed instructions to reset it and it worked as it should (yesterday ) so tried it out today and it has gone back as it was just shooting off without doing anything :-( , as anyone else has this problem is it poss the esc unit or the handset
    Thanks steve .
    Last edited by Bulb1; 10-05-2015 at 01:30 PM. Reason: Please remove wrong section

  2. #2
    RC Champion
    Join Date
    Jun 2015
    Location
    Brossard, QC
    Posts
    1,211
    You are in the wrong sub forum. Expect a mod to move this thread around soon...

    To answer your question, always turn on the transmitter (remote control, or handset as you call it.) first, and then turn on the car.

    If you are using the traxxas transmitter, there is also switch to modify the throttle position 50/50 or 70/30. Make sure its always at the same position.

  3. #3
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,522
    Thread moved.
    Alt-248 on the number pad =

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •