Results 1 to 6 of 6
  1. #1
    RC Enthusiast
    Join Date
    Apr 2012
    Location
    Redding CA
    Posts
    41

    Nitro rustler dies then won't restart for 5 minutes.

    I have a nitro rustler that has been boxed away for about 2 years. I'm trying to fix to sell to put towards a Revo 3.3. (I still have a jato so I'm not leaving you stadium truck guys). After fighting it to start I found a leak just below the hsn so I tightened that up but now I have a more serious problem I think is unrelated. If I do manage to get the rustler to start (drain an entire battery with ez start) it runs for 30 seconds to a minute (light and heavy throttle) it cuts off and dies even when under throttle.
    After it dies it will not start without sitting for at least 5 minutes. When I ran the truck in the past engine temps at the cooling head never exceeded 250. Any suggestions on what might be the problem? When I get home and have the chance I will start again and check for compression after it dies.

  2. #2
    RC Racer
    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    118
    Reset the carb settings to stock and attempt to tune from there. It's all covered in detail in your manual or on the support section on the website.
    -JuRRd

  3. #3
    RC Enthusiast
    Join Date
    Apr 2012
    Location
    Redding CA
    Posts
    41
    Hsn is 4 turns from closed and lsn is flush with inner ring. First thing I tried. Thanks for the input though. Any other ideas?also replaced both fuel lines in case of leaks.

  4. #4
    RC Racer
    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    118
    New or old fuel? Check glow plug?
    -JuRRd

  5. #5
    RC Enthusiast
    Join Date
    Apr 2012
    Location
    Redding CA
    Posts
    41
    Lost all compression after it warmed up. Problem found thanks for help

  6. #6
    RC Champion
    Join Date
    May 2014
    Location
    ohio
    Posts
    1,300
    Quote Originally Posted by SVC Crazed View Post
    Lost all compression after it warmed up. Problem found thanks for help
    if thats the case then rebuild the engine with a new p\s. then follow the original break in procedure and go from there. just make sure your carb is set back to factory.
    2.5r Pede, 2-speed O.S.21tm rusty , 3.3T-maxx

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •