Results 1 to 24 of 24

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    5,644

    Unhappy First to Break an X-Maxx?

    Hey guys, I was hoping I wouldn't have to start a thread like this so soon... I was out driving it filming it driving around on 6s getting footage for a running video for my hobby shop, and about 6-7 min into it, it slightly, and I mean barely even, drifted into a crack sideways in the walkway, moving maybe 2-3 mph, and there was a nice crack and pop sound. I have no idea how I managed to break it, but somehow I tore the top of the shock cap opening off... I can't post the video clip yet, for as it's my hobby shop's video we're going to use; but I'll try to post the video clips I'm talking about.

    *Sorry for the lengthy post again, but's it's full of info*

    Thankfully it broke just enough that it snaps back onto the ball link so I could keep driving it, but every 4-5 min it would pop off and I would have to snap it back on. My only guess to why it broke it the suspension can travel 1-2 inches farther than the shock lets it travel, so in theory if you pulled down really hard on a A-arm, it would snap like it did here. During the video I only rolled it once, but I drove it another 3 min after that before it actually popped off. I can't tell quite when it broke, or snapped, I only know when it popped off and became obvious... It's still usable, so I'm lucky, but I'm kinda annoyed at how fast it broke.

    On a side note, I'm not super impressed with the shocks yet. They look great, and the dampen impacts amazingly. After the first run (3-4 min) I noticed all 4 shocks had oil seeping out of them, to the point the spring retainer and rod end were wet with shock oil. I cleaned them off, thinking it was just the shocks breaking or wearing in or something, but all 4 of them are still leaking out oil out the bottom. I checked the bottom cap, and all of them are tight and seem to be correctly seated. Now that I've used it 5 times, or 30 min total, I'd say at least 10% of the shock oil has leaked out off all 4 shocks. I'm not sure if something is wrong with just my shocks, or if this is how they are all. It's a ongoing "test" if you will.

    Ok here's pictures of the broken shock cap tip...



    This is how far the suspension travels when you remove the top shock mount. Notice the gap between the top of the shock and shock mounting spot...



    It sill snaps on though...



    It's hard to tell in pictures, but you can see the shine from all the shock oil pooled in the spring retainer in this picture.



    In this one you can see the shock rod end is coated in shock oil too...



    I plan on contacting Traxxas first thing tomorrow to see if I can source a replacement somehow. I doubt they have one, but it's worth a try, and I'm hopping they can help me with it.
    Last edited by Wolfslash16; 12-02-2015 at 12:24 AM.
    Manager at LHS ~7 Years. I've seen some stuff lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •