Page 38 of 41 FirstFirst ... 283637383940 ... LastLast
Results 1,481 to 1,520 of 1620
  1. #1481
    RC Enthusiast
    Join Date
    Sep 2018
    Posts
    39
    Changed pinion and spur to 20/46.

    Changed paddle tires back to stock tires

    I started a thread last night on "best way to paint or hydro dip" bodys.... but cant find it. Did it get deleated by mod???? Does anyone know the best way to "paint" these bodys? Plz lmk thanks
    Last edited by Double G; 04-10-2019 at 12:52 PM.

  2. #1482
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,530
    Quote Originally Posted by Nitro Blowin View Post

    I started a thread last night on "best way to paint or hydro dip" bodys.... but cant find it. Did it get deleated by mod???? Does anyone know the best way to "paint" these bodys? Plz lmk thanks
    Read your private message I sent to you five hours ago.
    The Super Derecho

  3. #1483
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Got my servo horn replaced and now my truck is in one piece. Happy now.

  4. #1484
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Installing fastlanerc bulletproof gears set


    Sent from my iPhone using Tapatalk
    "AVENGED SEVENFOLD "

  5. #1485
    RC Qualifier
    Join Date
    Apr 2007
    Location
    Long Island, NY
    Posts
    361
    Quote Originally Posted by PATS4LIFE View Post
    Installing fastlanerc bulletproof gears set


    Sent from my iPhone using Tapatalk
    Looks like a killer setup.......

  6. #1486
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239

    What did you do with your X-Maxx today?

    Quote Originally Posted by PATS4LIFE View Post
    Installing fastlanerc bulletproof gears set


    Sent from my iPhone using Tapatalk
    I agree. Looks good. Curious why youíd delete the center diff though. I havent managed to damage any of my gearing, I could see myself getting the diff setup and pinions. Now I say this I will blow something up. Other than looking absolutely awesome(then disappearing) why billet cups?
    Last edited by Gripdog7205; 04-12-2019 at 09:00 PM.

  7. #1487
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Not sure what happened here,ran the truck maybe less that 5min all of sudden throttle diminished and then no respond and notice the motor wire weren’t attach anymore
    Anyone tell me what could possibly went wrong here?

    BTW it’s first run on the motor leopard 5892(1340kv)

    Sent from my iPhone using Tapatalk
    Last edited by PATS4LIFE; 04-13-2019 at 10:31 AM.
    "AVENGED SEVENFOLD "

  8. #1488
    RC Qualifier
    Join Date
    Jun 2012
    Location
    United Kingdom
    Posts
    877
    Looks like they did not solder the connectors on at all! If you have a good iron you could do this yourself. Need heat shrink etc to.

  9. #1489
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by o0wiz0o View Post
    Looks like they did not solder the connectors on at all! If you have a good iron you could do this yourself. Need heat shrink etc to.
    That’s what I was thinking,probably poor solder connection,you think it can cause the motor to get really hot also like 2-3 min run I touched the motor and it feels really hot and it was early morning run @ 60degrees temp.
    "AVENGED SEVENFOLD "

  10. #1490
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by PATS4LIFE View Post
    Thatís what I was thinking,probably poor solder connection,you think it can cause the motor to get really hot also like 2-3 min run I touched the motor and it feels really hot and it was early morning run @ 60degrees temp.
    Yeah. No tinning was done. Thatís really slack on the leopard side. Iíd say that was your heat issue. Are you running 8S, and whatís your gearing?

  11. #1491
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by Gripdog7205 View Post
    Yeah. No tinning was done. That’s really slack on the leopard side. I’d say that was your heat issue. Are you running 8S, and what’s your gearing?
    Yes I’m running on 8s with 1.5M 30/30 and mesh is fine
    Also have CC BEC 2.0 @7.4V for my savox servo
    "AVENGED SEVENFOLD "

  12. #1492
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by PATS4LIFE View Post
    Yes Iím running on 8s with 1.5M 30/30 and mesh is fine
    Also have CC BEC 2.0 @7.4V for my savox servo
    Was your input shaft really hot as well. I never had good luck with the belt drive, due to tension/heat issues. I have a thread about it. Either way your geared 1:1 which wonít work with your motor choice. Iíd fix the motor leads and gear down a bit.

  13. #1493
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by Gripdog7205 View Post
    Was your input shaft really hot as well. I never had good luck with the belt drive, due to tension/heat issues. I have a thread about it. Either way your geared 1:1 which won’t work with your motor choice. I’d fix the motor leads and gear down a bit.
    No input wasn’t as hot as the motor itself,I’ll gear down once I figured how to solder the copper wires on the motor,if not I’ll probably get me CC 2028 motor.

    Are still running drive belt?thought about it but I wasn’t sure about tensioning.
    "AVENGED SEVENFOLD "

  14. #1494
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    No Iím not. For some reason I thought you were. I see now youíre running mod 1.5. I prefer gears very much. I would stick with the leopard motor, I really like mine. If I swapped it would be to a TP motor.

  15. #1495
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by Gripdog7205 View Post
    No I’m not. For some reason I thought you were. I see now you’re running mod 1.5. I prefer gears very much. I would stick with the leopard motor, I really like mine. If I swapped it would be to a TP motor.
    I will try solder the connectors back on Leopard motor,I had the same motor on my maxx 6s before and had no issues.
    Thought about the TP motor also but I keep reading about people breaking shafts on them and warranty aren’t good.
    "AVENGED SEVENFOLD "

  16. #1496
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by PATS4LIFE View Post
    I will try solder the connectors back on Leopard motor,I had the same motor on my maxx 6s before and had no issues.
    Thought about the TP motor also but I keep reading about people breaking shafts on them and warranty arenít good.
    All good points. I really donít want for more. Iím running the 5898 1100kv. Geared 37/46. I have a 39 but have never run it.

  17. #1497
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Well my leopard 5892 1340kv crap out on me,it just keeps overheating since the wire connectors came off,I replaced the connectors with new ones I even had someone solder it professionally but it’s still overheating


    But anyways I ordered 950kv 8pole brushless motor to replace the leopard motor so as for now back to stock motor.



    Requests regarding product support for non-Traxxas is not allowed here.
    Last edited by Double G; 04-17-2019 at 04:29 PM.
    "AVENGED SEVENFOLD "

  18. #1498
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Ordered me fastlanerc billet heatsink with fasltane dual fans and ABC3 complete bearing set
    "AVENGED SEVENFOLD "

  19. #1499
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,084
    Quote Originally Posted by PATS4LIFE View Post
    Not sure what happened here,ran the truck maybe less that 5min all of sudden throttle diminished and then no respond and notice the motor wire weren’t attach anymore
    Anyone tell me what could possibly went wrong here?

    BTW it’s first run on the motor leopard 5892(1340kv)

    Sent from my iPhone using Tapatalk
    Why are your 3 motor wires wrapped up so tight with heat shrink? They should be loose around the bullet connectors.
    The ReglarGuy is kid tested and father approved.

  20. #1500
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by ReglarGuy View Post
    Why are your 3 motor wires wrapped up so tight with heat shrink? They should be loose around the bullet connectors.
    I just did for added protection
    Anyways sent motor back if warranty will cover but haven’t received any update since they received it Wednesday and I’ve been emailing them and no responds yet and RcJuice don’t even have a phone # that I can call listed on their site:/
    "AVENGED SEVENFOLD "

  21. #1501
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Ordered leopard 58113 V2 motor 870kv
    "AVENGED SEVENFOLD "

  22. #1502
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,084
    Quote Originally Posted by PATS4LIFE View Post
    I just did for added protection
    Anyways sent motor back if warranty will cover but haven’t received any update since they received it Wednesday and I’ve been emailing them and no responds yet and RcJuice don’t even have a phone # that I can call listed on their site:/
    If I may suggest, you should consider using only a zip-tie (or, something comparable in size) not so close to your bullet connectors, but about an inch or so back.
    Last edited by ReglarGuy; 04-27-2019 at 03:19 AM.
    The ReglarGuy is kid tested and father approved.

  23. #1503
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by ReglarGuy View Post
    If I may suggest, you should consider using only a zip-tie (or, something comparable in size) not so close to your bullet connectors, but about an inch or so back.
    Will do thanks for the tip
    "AVENGED SEVENFOLD "

  24. #1504
    RC Enthusiast
    Join Date
    Sep 2018
    Posts
    39
    This all took me few days being life has been busy.


    Totally Dissembled the xmaxx.
    Cleaned all parts.
    Installed RC screws stainless screw set
    Replaced all bearings with RC bearing set
    Replaced front diff oil with 30k weight
    Refreashed center diff with 20m weight
    Replaced rear diff with 50k weight
    Replaced rear hubs with RPM oversize hubs
    Replaced spur gear with 46T GDS gear
    Replaced pinion with 20T
    Added washers for rear bumper screws to wheelie bar (screws were pulling through)
    Added synthetic marine grease to all metal on metal gears, except driveshaft and pinion/spur.
    Added dielectric grease to reciever box seal.
    Placed tape over holes inside rims of stock tires. (Prevent water from getting inside tires)

    The RC screw kit left out few screws like steering servo and think something else already forgot lol 95% complete kit, tons of extra screws tho. Few screws were also different length but 1-2 millimeter difference so seems to work fine..

    The RC screw bearing kit left out bearings for the wheelie bar wheels 95% complete kit few extra bearings.

    Dont think I'm leaving anything out. It was a big project for only having the truck a few months and never taking it apart other than replacing spur/pinion, esc and reciever.





    Sent from my SM-G965U using Tapatalk

  25. #1505
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Just received my leopard 58113 V2 870kv motor,next to it is 56113 8 pole 960kv motor from primal Rc


    Sent from my iPhone using Tapatalk
    "AVENGED SEVENFOLD "

  26. #1506
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Installed 58113 V2 motor with fastlane rc billet heatsink/dual fans with led lights.


    Sent from my iPhone using Tapatalk
    "AVENGED SEVENFOLD "

  27. #1507
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by PATS4LIFE View Post
    Installed 58113 V2 motor with fastlane rc billet heatsink/dual fans with led lights.


    Sent from my iPhone using Tapatalk
    Lol. Those fans looks so tiny on the giant motor


    Sent from my iPhone using Tapatalk

  28. #1508
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Quote Originally Posted by Gripdog7205 View Post
    Lol. Those fans looks so tiny on the giant motor


    Sent from my iPhone using Tapatalk
    Yes it is but it cools the motor down to at least 40degrees.
    "AVENGED SEVENFOLD "

  29. #1509
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by PATS4LIFE View Post
    Yes it is but it cools the motor down to at least 40degrees.
    Oh Iím not hating. I run fans too. I will say for what they charge, they should be larger.


    Sent from my iPhone using Tapatalk

  30. #1510
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,155
    Just received my x maxx work stand..


    Sent from my iPhone using Tapatalk
    "AVENGED SEVENFOLD "

  31. #1511
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,084
    If you had bigger fans that went out further past the very top of your heatsink, you would get even better cooling.

    The ReglarGuy is kid tested and father approved.

  32. #1512
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    345

    What did you do with your X-Maxx today?

    This is what Iím going to be running

    Iím not done installing it yet
    It will need its own power
    Sent from my iPhone using Tapatalk

  33. #1513
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,084
    I really like the frame you made. You should consider two fans, and have those two fans get their power from your two Lipo's or BEC...maybe even three fans. It looks like your frame could handle three fans easy. Don't worry about the current drawing from your batteries. The small fans we use for our cooling draw very little current.
    The ReglarGuy is kid tested and father approved.

  34. #1514
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    345
    1 the fans are 60x60x40 and my motor is a 56112 so two will run in to the motor wires

    2 they are 12v fans they draw 3.5-4 amps and I donít believe there is a 12v bec ( send a link of Iím wrong)

    3 can I run them on the balance port or would I have to make a splice?


    Sent from my iPhone using Tapatalk

  35. #1515
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by Overpowerxmaxx View Post
    1 the fans are 60x60x40 and my motor is a 56112 so two will run in to the motor wires

    2 they are 12v fans they draw 3.5-4 amps and I donít believe there is a 12v bec ( send a link of Iím wrong)

    3 can I run them on the balance port or would I have to make a splice?


    Sent from my iPhone using Tapatalk
    The one Iím installing is adjustable up to 12vdc.



    Somehow builds are never done....

  36. #1516
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    345

    What did you do with your X-Maxx today?

    Once itís connected do you just plug the fan in to the receiver


    Sent from my iPhone using Tapatalk
    Last edited by Overpowerxmaxx; 06-09-2019 at 09:46 AM.

  37. #1517
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by Overpowerxmaxx View Post
    Once itís connected do you just plug the fan in to the receiver


    Sent from my iPhone using Tapatalk
    Well 12vdc will burn a receiver up. You could just use it for the fans if you choose. But normally youíd connect it directly to the battery and RX. I set mine for 7.25vdc. Best for the receiver and servo. Stock receiver will not support above 6.


    Somehow builds are never done....

  38. #1518
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    345
    How could I power the fans on the Balance plug or how would I have to splice and where would I have to splice?


    Sent from my iPhone using Tapatalk

  39. #1519
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,239
    Quote Originally Posted by Overpowerxmaxx View Post
    How could I power the fans on the Balance plug or how would I have to splice and where would I have to splice?


    Sent from my iPhone using Tapatalk
    Just solder + and - to the esc battery connection from the BEC. Then set the voltage and use red and black output to power the fans. This is just an option. Iíd use a different set of fans personally, get something a little less huge that runs on an Typical voltage. Then you could wire the bec in a typical fashion.


    Somehow builds are never done....

  40. #1520
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    345
    How could I run with no bec


    Sent from my iPhone using Tapatalk

Page 38 of 41 FirstFirst ... 283637383940 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •