Results 1 to 3 of 3

Thread: Motor or esc?

  1. #1
    RC Enthusiast
    Join Date
    Nov 2015
    Posts
    20

    Motor or esc?

    I got my son a SST for Christmas and it has 2-3 batteries through it. Today we went out to where they're building our house and were driving around. He'd been driving in some wet dirt that wasn't really accumulating on the truck. I went to help my daughter with the 4 wheeler and apparently he found some really wet mud/clay and it picked up a bunch on the tires and the truck went into thermal protection. I left my temp gun at home so I don't know how hot it got, but after getting it home, cleaning it up, and driving it, the truck is very slow. Like maybe half speed. So is it the motor or esc??? We are running a 2s lipo, the light stays green and seems normal, but there's just no power anymore.
    Rustler VXL
    '69 Mustang (6.12@112)

  2. #2
    RC poster
    Join Date
    Dec 2015
    Posts
    11
    I would say you burnt up the motor. Sadly these little trucks were not really designed to be run on 2s with stock gearing. My latrax rally got to 180 degrees in 15 minutes of lighter driving, on a 5 cell NIMH! My bet is the motor overheated, and he damaged it. But thats fine, the motors are cheap and easy to replace, or for 80 or 90 bucks, you can pick up a nice little castle system in 1/18 scale.

  3. #3
    RC Enthusiast
    Join Date
    Nov 2015
    Posts
    20
    Ha..he's 6, so I think we will stick with stock. I'll grab one and see if it fixes it. Thanks.
    Rustler VXL
    '69 Mustang (6.12@112)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •