Hope you can help, I've been looking round these forums but did not find a similar problem (yet).

I bought myself a new TQi receiver with TSM capability, I assumed it would be factory bound/linked but apparently not. So I tried to bind it
1. power on the transmitter while pressing the set button (transmitter slowly blinks red)
2. power on the model/receiver while pressing the link button
3. both leds become..... not green, the transmitter starts to blink quickly red (link error) the moment the receiver is powered and the receiver keeps on blinking red.

I tried binding my old (6519) receiver to the transmitter, no problem. So the transmitter can work and the procedure is correct. So conclusion: receiver bad. The shop where I bought the combo gave me good service and sent me a second receiver, same problem however.


Now it could be that I was sent an older transmitter (with multi-function knob) that is not (yet) compatible with the TSM receiver but before I spent more cash on buying the Bluetooth module (6511) to firmware update the transmitter with my phone can somebody please confirm this behavior and give me reasonable hope this will fix things?

Thank you,