Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Sep 2019
    Posts
    1

    throttle inop slash 4x4 :unsure:

    hello ppl, i'm new to this whole RC thing and i need some help if you are up for the challenge. i just recently acquired a Slash from a guy that is no longer around. the one thing that he told me that it needs new battery's. i have replace the batteries in the truck and the transmitter/controller. when powering up the system the receiver only connects about 1/2 the time and when it does the drive-line is unresponsive. any ideas on what i can do to get this truck up and running? i would attach a pic to show what am working with but i'm not able to add attachments. it does have the mamba monster monster truck 1/8th scale (motor servo i think) and 2 each 2075 steering servos attached.

  2. #2
    RC Competitor
    Join Date
    Jun 2012
    Posts
    53
    Sounds to me like it needs to be re-binded to the transmitter


    Sent from my iPad using Tapatalk Pro

  3. #3
    RC Turnbuckle Jr. Squeegie's Avatar
    Join Date
    Jun 2014
    Location
    Southern California
    Posts
    7,568
    Welcome to the Traxxas forums!

    Could be a binding issue, but does the rig steer fine, just no throttle? If yes, check the wires between the motor and the ESC. Make sure that are firmly attached.

    Also, do you have a Slash? Sounds more like an E-Revo since you say you have 2 steering servos.

    Good luck and have fun!
    Creativity is intelligence having fun. -Einstein

  4. #4
    RC Enthusiast
    Join Date
    Aug 2019
    Posts
    36
    I would also check the wire from the esc to the receiver and make sure it is firmly plugged in.

  5. #5
    RC poster
    Join Date
    Jan 2019
    Posts
    5
    Quote Originally Posted by smeezy View Post
    I would also check the wire from the esc to the receiver and make sure it is firmly plugged in.
    Not only make sure it is plugged in securely, also make sure it is plugged in to the proper spot. The first 2 plugs in the receiver are the same channel, the third plug is channel 2, IIRC channel 2 is throttle to the ESC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •