Results 1 to 4 of 4
  1. #1
    RC Enthusiast
    Join Date
    Jan 2016
    Posts
    37

    Castle Creations 3800kv questions

    So i just installed my Castle Creations sv3 Sidewinder SCT 3800kv motor and the sct esc into my completely stock Slash 2wd. I use SMC 40c 5000mah batteries and whenever i go full throttle, the motor makes a high pitch sound for a second, then gets traction. I think its just tire spin, because whenever i end the run, the tires are hot/warm. I use 23t pinion and 86t spur, and i was wondering if this was too high. Temps are relatively low, feels like just under 100 because i can keep my hand on it for a long time and it feels warm, not hot. The gearing chart it comes with says 14t-19t with a 90t spur, but i want a higher top speed than that. Anyone know the best for 40-50 mph top speed, but still enough torque for offroad?

    My Slash weighs under 4 lbs.
    Last edited by ncslash; 03-09-2016 at 04:21 PM.

  2. #2
    RC Turnbuckle Jr. Jezza's Avatar
    Join Date
    Feb 2013
    Location
    Montreal, Canada
    Posts
    5,590
    Sound like your slipper clutch is too loose.

    Also do not do the geussing game , get a temp gun, which are relatively cheap. It will spare the regret of fiding out later should you kiss the esc and motor good buy from overrheating.

    On a 2wd , the sv3 with a 3800 should handke 3s easily, but dochrck off the specs, I had an mmp with the same motor so it was a big different.

    Whe you get a temp gun, gear from 16/90or 86 upwards and ind the ideal gesring fof you on 2s and 3s equally were thd temps are at the ideal seting , I like itmax ar 160 f for both motor and esc.
    Last edited by Jezza; 03-09-2016 at 05:04 PM.
    Live life to the fullest

  3. #3
    RC Qualifier
    Join Date
    Jan 2014
    Posts
    377
    yup sounds like slipper clutch.

    +1 on IR temp gun and they are inexpensive.

    try 83t spur and 24t or 26t pinion-I will be trying 83t/28t p soon

  4. #4
    RC poster
    Join Date
    Feb 2016
    Posts
    6
    its probably a mix of clutch slipping and tire spin. i put a hobbywing 3800KV 4pole setup in my 2wd, got the clutch tight enough to not slip but within 5-6 packs rear tires were bald lol. depends on where you want your give and take. i run 23/86 on 2s and 3s and have had no issues. mostly pavement on 3s. 2s is everything.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •