Results 1 to 12 of 12

Thread: No Power

  1. #1
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    582

    No Power

    Our Revo was sitting for a couple weeks. It used to run fine before. I tried two sets of batteries and turned it on but nothing. No fan spinning or lights. Do you think the ESC burnt out and is there a way I can test it? Do you need the motor connected for the ESC to work?

  2. #2
    RC Racer Rooky78's Avatar
    Join Date
    Feb 2016
    Location
    Naptown
    Posts
    231
    Silly question, but are the batteries charged? If you left them in the truck, the may have drained.

  3. #3
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    582
    They are fully charged. Even if they were drained wouldn't the lights and even the fan turn on?

  4. #4
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    582
    I just received this email. Totally forgot I submitted a ticket.

    First try putting fresh batteries in the radio and in your vehicle. Make sure the antenna on your receiver is not cut short, and that it is all the way out to the end of the antenna tube. Make sure the antenna on the radio is up (vertical) and that it is not damaged. Check the plugs in your receiver to make sure they are secure, that the steering is plugged into channel 1, the ESC is plugged into channel 2 and that none of the wires are pinched frayed or kinked.

    Next reset your transmitter to its factory default settings. This procedure is different from the one in your Owner's Manual.

    Start with radio turned off.

    Hold both menu and set.

    Turn radio on

    Release menu and set slow red blinking light

    Hold menu and set till light changes to green blink

    Release menu and set

    While holding steering at full left, press set.

    While holding steering at full right, press set.

    Light changes back to red blink

    While holding full throttle press set.

    While holding full breaks, press set.

    Light should now be solid green, factory endpoints reset has been finished.

    Reset your transmitter to its default settings. https://traxxas.com/video/Accessorie...TQ-24GHz-High-

    1.Install the AA batteries in the transmitter. Press and hold the SET button. Switch the transmitter on. The STATUS LED will flash. Release the button.

    2.Press and hold the receivers LINK button. Switch the receiver on. The receiver LED will flash.

    3.When both LEDs stop flashing (this will take just a moment or two), the system is bound and ready for use. Confirm that the steering and throttle operate properly before driving your model.

    If it is still not working program the transmitter. https://traxxas.com/video/Accessorie...-TQ-24GHz-High

    All the programming videos are on this page. https://traxxas.com/support/video

    Make sure you are in the correct LiPo or non LiPo mode. Low voltage detection mode should only be used with LiPo batteries. Refer to the Castle addendum and the Castle Drivers Ed guide Manual you received with the vehicle for full speed control operation details

    http://www.castlecreations.com/suppo...s_ed_guide.pdf

    Follow these instructions to reprogram the speed control:
    1. Install the batteries of your choice in the battery compartments and plug the batteries into the speed control.
    2. Switch on your transmitter.
    3. Hold full throttle while you switch on the MXL-6s controller. After a few seconds, you will hear multiple tones and the RED LED will light.
    4. Hold full brake. After a few seconds, you will hear multiple tones and the YELLOW LED will light.
    5. Release the trigger to the neutral position. After a few seconds you will hear multiple tones and ALL THE LEDs will light.
    6. Wait a few more seconds for the speed control to arm, indicated by a double-tone. You are now ready to drive.

    Unplug the steering servo from the receiver and see if the ESC programs normally. A shorted servo can cause the system to fail.

    Finally remove the on/off switch and connect the wires directly to see if it is just a switch issue. Turn the ESC on and off by plugging and unplugging the battery.

    If it still does not work it sounds like you need to send your MXL-6s ESC and MXL-6s motor (remove the pinion gear and any hardware) to us for inspection/repair. There is a 30 day warranty on all Traxxas electronics. Beyond that you can take advantage of the lifetime extended warranty (US and canada only). Under that program there is a repair charge of $110 for the speed control and $100 for the motor plus $5 shipping within the US. Shipping to Canada, Alaska, Puerto Rico and Hawaii is $15.00.

    If you have not already registered your vehicle on our web site, please do so at https://traxxas.com/register

    Once you have registered respond to this e-mail with the vehicles serial number your name, phone number, address and your Zip code. I will generate an RMA number for you to send it in.

    Here is the service and repair information. https://traxxas.com/support/Traxxas-Warranty-Service



    Best regards
    Steve
    Traxxas Customer Support



    Please include all previous e-mails in your response to prevent delays in receiving support.



    If you need immediate assistance please contact our Customer Service department Monday through Friday, 8:30am to 9:00pm Central Time at one of the following numbers:

    US Customers 1-888-TRAXXAS (Toll Free)
    Outside of US 001-972-549-3000

  5. #5
    RC Turnbuckle Jr. Jezza's Avatar
    Join Date
    Feb 2013
    Location
    Montreal, Canada
    Posts
    5,590
    I love traxxas customer support, just awsome, hope you get her running now.
    Live life to the fullest

  6. #6
    RC Champion MaXXL's Avatar
    Join Date
    Nov 2015
    Location
    South Florida
    Posts
    1,222
    So after youve tried the above things, let us know what happens please
    10 RCs and counting 😅

  7. #7
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    582
    I can't do any of the above as the ESC won't turn on. I will turn it in to Traxxas to check out.

  8. #8
    RC Racer
    Join Date
    Jan 2015
    Location
    Nova Scotia, Canada
    Posts
    142
    sounds like the on off switch on the esc. just disable the switch

  9. #9
    RC Racer C0BRAX's Avatar
    Join Date
    Feb 2016
    Location
    Colorado
    Posts
    229
    Quote Originally Posted by mudzlinger View Post
    sounds like the on off switch on the esc. just disable the switch
    +1 The switches are easily shorted.
    Happy Motoring!

  10. #10
    RC Racer
    Join Date
    Jan 2015
    Location
    Nova Scotia, Canada
    Posts
    142
    they hate water!! they talk about the fans not being waterproof, but everybody forgets about the switch. spray with silicone spray for future reference. happy bashin!

  11. #11
    RC Champion
    Join Date
    Jun 2015
    Location
    Brossard, QC
    Posts
    1,211
    Received my sidewinder 3. Washed it, and the next day, the switch was dead.

    Sent from my ONE A2005 using Tapatalk

  12. #12
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    582
    I'll check out the switch. Funny though I washed it down maybe a month ago. Then I ran the car and then it sat for a couple weeks. Now it stopped working. Since this is my wife's car I installed a castle MM2/2200kv combo so it's all good now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •