Results 1 to 10 of 10

Thread: SST issues!

  1. #1
    RC poster
    Join Date
    Apr 2011
    Posts
    3

    SST issues!

    Okay, so i bought the SST a couple of months ago, never got to driving it i drove it once. The ground was damp and i went to use it today and the servo feels stripped and it wont turn on. No lights on the ESC or receiver. When i last drove it, didn't hit any walls or hard objects to break the servo. Should i just get new electronics or call traxxas?

  2. #2
    RC poster
    Join Date
    Apr 2016
    Posts
    13
    With no power to any electronics, my first thought would be to check the battery to see if it has a charge. Always get the obvious out of the way first.

    Also, make sure the battery connector is "locked" and has good contact with the ESC side of the connector. I've hooked up my battery thinking is was locked and started running only to have the truck stop dead. The battery side of the connector wasn't locked down and started to back out, thus killing the power to the electronics.

  3. #3
    RC Enthusiast
    Join Date
    Jul 2012
    Location
    Finland
    Posts
    31
    Tamiya connector is useless.

  4. #4
    RC poster
    Join Date
    Apr 2016
    Posts
    13
    Quote Originally Posted by allu 6 View Post
    Tamiya connector is useless.
    Yeah, and they have a tendency to melt if you run a lot of current through them. I have some Deans connectors sitting on my bench, but I've been too lazy to install them.

  5. #5
    RC poster
    Join Date
    Apr 2011
    Posts
    3

    SST issues!

    I've made sure it was plugged in and charged plenty of times. I might just order new parts. Is it possible to go brushless? would be a heck of a machine lol

    Traxxas has a strict language policy. A word filter operates to change inappropriate words to *s. When you see these in your post, you MUST edit them out.
    ksb51rl
    Last edited by ksb51rl; 07-21-2016 at 07:54 PM.

  6. #6
    RC Racer
    Join Date
    Apr 2015
    Posts
    124
    I'd try rebinding your transmitter to your receiver, if that doesn't work try getting a new battery, if that's not the problem get a new receiver, if that doesn't work new esc

  7. #7
    RC poster
    Join Date
    Apr 2016
    Posts
    13

    SST issues!

    Quote Originally Posted by tommeents1 View Post
    I've made sure it was plugged in and charged plenty of times. I might just order new parts. Is it possible to go brushless? would be a heck of a machine lol
    People do put brushless systems in these, but the stock diffs and axles really aren't up to the task.
    Last edited by ksb51rl; 07-21-2016 at 07:54 PM.

  8. #8
    RC poster
    Join Date
    Apr 2011
    Posts
    3
    I'll be sure to do that. Thanks!

  9. #9
    RC poster
    Join Date
    Jul 2016
    Posts
    4
    So I just opened and got my battery charged. went to go and can turn just fine but no forward or reverse. I've tried and ouble checked everything.

  10. #10
    RC Enthusiast
    Join Date
    Jul 2012
    Location
    Finland
    Posts
    31
    Quote Originally Posted by macafellee View Post
    So I just opened and got my battery charged. went to go and can turn just fine but no forward or reverse. I've tried and ouble checked everything.
    Esc is broke.
    Slash 2wd,stampede 2wd,latrax sst

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •