Results 1 to 5 of 5

Thread: Twitchy?!!!

  1. #1
    RC Qualifier MilitaryRcDude's Avatar
    Join Date
    Nov 2014
    Posts
    325

    Twitchy?!!!

    Hey all I recently washed my Merv and it's been twitchy since. When ever I put throttle it hesitates then goes into forward. I think a bit of water may have gotten into the receiver box but I don't know about anything else that is bad
    Thanks, MilitaryRcDude

  2. #2
    RC Qualifier
    Join Date
    Mar 2016
    Location
    St. Helens, U.K.
    Posts
    631
    Sounds like a partial short circuit somewhere.
    Before any contacts corrode, assuming some moisture has got into the servo and / or Rx and / or ESC I'd put it in the sun for several hours.
    If moisture's difficult to get in, but has, then it'll likewise be difficult to get out.

    Al.

  3. #3
    RC Qualifier MilitaryRcDude's Avatar
    Join Date
    Nov 2014
    Posts
    325
    Okay that makes sense I will do so
    Thanks, MilitaryRcDude

  4. #4
    RC Enthusiast
    Join Date
    Apr 2016
    Posts
    24
    If it is still acting twitchy after you've dried it out I would unplug the servo and see if forward and reverse work. I've had two of the stock servos fail and both times it made the car act the way you're describing.

  5. #5
    RC Qualifier MilitaryRcDude's Avatar
    Join Date
    Nov 2014
    Posts
    325
    I have an aftermarket servo but I'll do what you said and see if it works also
    Thanks, MilitaryRcDude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •