Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jul 2016
    Posts
    7

    No Throttle, only Steering. Please help

    Hi everyone, I have the M41 boat with 2 Traxxas 3-cell 5000mah with 25C, 11.1v lipo batteries. I charged them with the Traxxas EZ-Peak Plus charger & I know they both work because I tried each one in my Slash. But when I turn on my radio, then plug in the batteries (because there is no on/off switch, correct?), the ESC makes a weird beeping sound & the steering works but no throttle. Can anyone help or give any ideas? It's really weird because I tested everything out the day I got it & both the steering & throttle worked. The boat is brand new. I really appreciate any help or remarks because I really want to drive this thing!

    Thanks so much,

    Sean

  2. #2
    RC Racer
    Join Date
    Mar 2016
    Location
    Colorado
    Posts
    242
    Iv'e had my 41 for 2 months and never had that issue, call Traxxas support, see what they say, only problem iv'e had is the antenna coming out of the mount, and of course the water cooler jacket leaking, which i'm not going to worry about until the hull is completely full of water after a hard run. HR aftermarket jackets are backordered.

  3. #3
    RC Racer
    Join Date
    Sep 2015
    Location
    Chesapeake, Va.
    Posts
    142
    We had the same issue once with the M41 but might have gotten lucky. We pushed the menu button [on the transmitter] once while every thing was on and regained all control again. Rude98 is right tho Traxxas Support is great, once I had pushed the red buttons on the top of the transmitter with my Spartan while it was on and it lost all communications and they talked me thru a transmitter reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •