Results 1 to 4 of 4

Thread: Fried Battery?

  1. #1
    RC poster
    Join Date
    Apr 2016
    Posts
    7

    Fried Battery?

    I have a Stampede 4x4 VXL. I've only run it a a half dozen times. I left the stock NIMH battery plugged into the Traxxas EZ-Peak Plus 4-amp charger. I didn't use the battery and truck as quickly as I expected (about a month). When I eventually plugged in the battery to the truck and pressed the On button, the truck didn't move. I plugged the battery back in the charger and it won't reach the green level that indicates a full charge.

    I'm guessing I fried the battery by leaving it on the charger too long?

    Please, if you only want to make "That's right, Stupid," remarks, just don't.

    Thanks.

  2. #2
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525

    Fried Battery?

    Hmmm....battery damage through overdischarge via parasitic losses from being connected to an unpowered charger? If so (and that's just a guess) that's a new one to me, but I'd say it is possible. Then again, I don't know anybody who has done this before. Again, hmmm...
    Alt-248 on the number pad =

  3. #3
    RC poster
    Join Date
    Apr 2016
    Posts
    7
    The charger was plugged in the entire time with the battery receiving power.

  4. #4
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525
    Well why didn't you say that before?!? Doesn't matter - I still got nothing. Except to ask exactly what is the charger showing?
    Alt-248 on the number pad =

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •