Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Aug 2016
    Posts
    1

    Exclamation Transmitter and Receiver Issues

    Hi, I am 14. I am new to Traxxas, and the Stampede 2wd is the only Traxxas I own. I demolished my receiver and was told by customer support to send in my receiver and transmitter to get replaced under warranty.

    After 2 weeks a 2 days, I received a new receiver... and then I realized Traxxas gave me a new Transmitter. I just tried to attach the receiver to the ESC and Transmitter, by plugging in the ESC to Channel 2, and the other one to Channel 1. By turning on the ESC and the Transmitter; The Transmitter light turned a solid green. The ESC rapidly flashed green. the Receiver stayed a solid red. By holding the Receiver's Link button and Transmitter button to Set everything; The Transmitter light slowly flashed green. The ESC light turned solid red. The Receiver rapidly flashed red.

    I've tried everything on YouTube and almost everything on these forums, and I'm out of options to my knowledge. I will list extra info below.

    Thanks for the help, JaredL

    RC: Stampede 2 Wheel Drive
    Battery: Charged (Original)
    Htz: 2.4 on Receiver and Transmitter
    ESC: XL5 (Original)
    Receiver: Brand New
    Transmitter: Brand New
    *Everything original was bought in Mid July, so a little over a month old.

  2. #2
    RC poster
    Join Date
    Jul 2016
    Posts
    18
    You are going to have to get access to the link but on your receiver in the truck. Hold down the Set button on the controller and turn it on while still holding the button. Then hold down the link button on the truck and turn truck on while still holding down the set button release both at the same time. I have a Traxxas slash 4x4 and that's how I did it with my 4CH controller I just got to operate a plow. I am still having trouble with the toggle switch on top but drive and steering is working fine. Also make sure the battery in the truck is charged and the controller battery's are charged. I know you said yours is charged but after a little while it will loose a charge. Hope this helped you. I wouldn't be too surprised if I messed up a step. I also saw the post date so I expect you got it working by now. Have fun running the stampede!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •