Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Aug 2012
    Posts
    3

    Can't go Full Throttle.

    After 2 or 3 weeks w/o taking my M41 to the water, today I decided to go to the lake, and every time I go Full Throttle, the boat cut-off power like if activating the Li-Po cut-off. I have to go to idle position in the control, and then go again. I can go 3/4 throttle and it behaves normally, but if i go full, then I get the power cut-off.

    Batteries are fully charged, no changes in the profile since last run, no warning lights on ESC.

    Any suggestions?

    Thanks,

    JB

  2. #2
    RC Competitor
    Join Date
    Aug 2016
    Posts
    96
    recalibrate the throttle for the ESC... Thats about the only thing I can think to do...

  3. #3
    RC Racer
    Join Date
    Mar 2016
    Location
    Colorado
    Posts
    242
    Call Traxxas support, find out what they say. Mine does this on occasion also. I'm going to call them and see if this is a common problem.

  4. #4
    RC Champion
    Join Date
    May 2002
    Location
    Midvale Utah
    Posts
    1,773
    Sounds like your battery just isn't up to the task. When you go full throttle, it tries to pull more power than your battery can supply, which make the voltage drop below the lvc threshold.
    Get newer/better batteries and you will find it doesn't happen.

    Fyi, leaving lipos fully charged for weeks at a time damages them. If you aren't going to use them for even a few days, you want to discharge them to around 40-60% charge. Most good chargers have a "storage" more. That's what it's for.
    Last edited by dacaur; 11-02-2016 at 11:18 PM.
    Dacaur

  5. #5
    RC poster
    Join Date
    Aug 2012
    Posts
    3
    I think you are right Dacaur! I used another pair of batteries and it worked fine. Nevertheless I started having the same issue with the current packs. So I ordered fresh new batteries. I will keep you posted!

  6. #6
    RC Racer
    Join Date
    Mar 2016
    Location
    Colorado
    Posts
    242
    Mine stutters on to fast cornering and corner exit, annoying but it's a driving issue, the wider I sweep the less stuttering I have on exit and then full throttle. You have to try and stay out of your turn wake or it will chine walk like crazy. I've got over 3 dozen lake runs and haven't blown over or had to recover my rig yet.

  7. #7
    RC Enthusiast
    Join Date
    Dec 2016
    Location
    Lake Norman NC
    Posts
    32
    Good info on this post, Thanks guys from a new RC boat owner.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •