Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Feb 2016
    Posts
    17

    TQi 1633 Problems.

    Hi guys.

    I have a Rustler VXL and currently am having connection problems.
    I try to bind the TQi 1633 to my TQi transmitter, but the receiver shows that it is not connected. Any solutions? Should i send to traxxas HQ for repair or buy a new part? Thanks guys.

  2. #2
    RC Qualifier Rich2's Avatar
    Join Date
    Feb 2014
    Location
    Western New York
    Posts
    627
    Quote Originally Posted by Shedbruh View Post
    Hi guys.

    I have a Rustler VXL and currently am having connection problems.
    I try to bind the TQi 1633 to my TQi transmitter, but the receiver shows that it is not connected. Any solutions? Should i send to traxxas HQ for repair or buy a new part? Thanks guys.
    I think you may be referring to 6533, right?
    If you were, did it come originally in that truck? If it didn't you'll need the Bluetooth module for your transmitter to start with as it will need to update the receiver.

    Sent via Tapatalk

  3. #3
    RC poster
    Join Date
    Feb 2016
    Posts
    17
    Yes I meant the 6533 for the Rustler.

    It was the stock transmitter that came in the box. But now whenever I try binding the radio, the esc blinks green quickly and the receiver stays solid red.

    Sorry for late reply.

  4. #4
    RC Racer
    Join Date
    Oct 2016
    Location
    utica ny
    Posts
    115
    you need to reset the reciever and connect to you device again should fix it
    Everything dies..everything..no,no,no,no

  5. #5
    RC poster
    Join Date
    Feb 2016
    Posts
    17
    How do you reset the receiver?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •