Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Feb 2016
    Posts
    17

    TQi 6533 Receiver not binding to TQi Transmitter. Help please.

    Hello.

    My current model is a Rustler VXL.

    Whenever i try to turn on my ESC it blinks green and the receiver is red. I try binding with the transmitter to the receiver but there is no response to either one of the devices. The ESC continues to blink green and the receiver stays solid red.

    Is there a way to fix this problem.

    Or do I have to send to repair stations at Traxxas? Thanks.

  2. #2
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525
    Are you sure your throttle trim is at zero (centered)?
    Alt-248 on the number pad =

  3. #3
    RC poster
    Join Date
    Feb 2016
    Posts
    17
    If you're talking about the 50/50 or 70/30, I have 50/50 throttle. Unless it is something else.

  4. #4
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,525
    Quote Originally Posted by Shedbruh View Post
    If you're talking about the 50/50 or 70/30, I have 50/50 throttle. Unless it is something else.
    The default function of the Multi-function knob is TSM control or throttle trim.
    Alt-248 on the number pad =

  5. #5
    RC poster
    Join Date
    Feb 2016
    Posts
    17
    Yes the multi function knob centered at 0. Throttle is also 50/50.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •