Results 1 to 5 of 5
  1. #1
    RC Racer
    Join Date
    Dec 2014
    Posts
    106

    Castle 2200 mamba x with spectrum dx4c throttle cutoff?

    OK so I have the mentioned motor esc and remote.

    Put in new smc batteries, everything is new. And it does something really weird. If I mash the throttle it starts to go way under powdered and about 10 mph just cuts off. But if I mash the gas again while it's coasting it will about flip over backwards and haul bogey. Now what the heck is going on?

    I did a reset on esc went thru all the castle programming modes selecting the right ones etc. So I'm completely stumped.

  2. #2
    RC Racer
    Join Date
    Dec 2014
    Posts
    106
    The esc also after about 20 seconds of being on keeps giving me a beep beep ( 2 beeps) signaling a start fail? That the esc failed to start the motor? But it'll still run just in its weird way where I can't use all the power and when I mash the throttle it cuts off and coasts after like 20 feet? This is frustrating

  3. #3
    RC poster
    Join Date
    May 2016
    Posts
    15
    Did you upgrade the esc firmware?

    Sent from my SM-G930T using Tapatalk

  4. #4
    RC Racer
    Join Date
    Dec 2014
    Posts
    106
    No I did not. Is there a link on how to do that

  5. #5
    RC Racer
    Join Date
    Dec 2014
    Posts
    106
    So Do i need to buy this 100$ castle link just to fix my brand new ESC?

    http://www.castlecreations.com/en/se...nk-010-0121-00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •