Results 1 to 3 of 3
  1. #1
    RC Qualifier
    Join Date
    Mar 2016
    Posts
    469

    My Exprence with the DTS-1

    I recently picked up a TRAXXAS DTS-1 Drag System from my LHS. So hear is my review of the DTS-1

    Took me 3 days of trying to set the DTS-1 up called TRAXXAS on the 4th day the tech was very helpful & walked me though all the steps. Turned out I did not have the laser beams set right & out of adjustment The yellow blocks have a guide on the side where the beams need to be at simple fix.

    Tried hitting the set button for a race NOTHING no pre stage light or stage lights tried relinking everything on the TRAXXAS LINK APP on my XO-1 remote everything kept getting no connection notice... UMM call up TRAXXAS again I was told I need to download the firmware OK no problem. Pack up the DTS-1 go home download the firmware to my Android cell GO back out & reset up the DTS-1 got the Beams all to line up link both start & finish but the darn TQI stuff wont link call TRAXXAS up again & I was asked by the TECH if I am using an Android based system I said yes. The Tech that is half my problem for some reason Android APPS don't work well on the TRAXXAS LINK System the tech said I should find a friend that has an APPLE product such as a tablet to download the Firmware Than after that the DTS-1 should operate normal.

    Well I don't know anyone that has an apple phone so never got chance to download the firmware

    But the DTS-1 works fine in plane mode

  2. #2
    RC Turnbuckle Jr. Briber's Avatar
    Join Date
    Dec 2015
    Location
    St. Peters, MO
    Posts
    3,325
    Quote Originally Posted by grave75 View Post
    I recently picked up a TRAXXAS DTS-1 Drag System from my LHS. So hear is my review of the DTS-1

    Took me 3 days of trying to set the DTS-1 up called TRAXXAS on the 4th day the tech was very helpful & walked me though all the steps. Turned out I did not have the laser beams set right & out of adjustment The yellow blocks have a guide on the side where the beams need to be at simple fix.

    Tried hitting the set button for a race NOTHING no pre stage light or stage lights tried relinking everything on the TRAXXAS LINK APP on my XO-1 remote everything kept getting no connection notice... UMM call up TRAXXAS again I was told I need to download the firmware OK no problem. Pack up the DTS-1 go home download the firmware to my Android cell GO back out & reset up the DTS-1 got the Beams all to line up link both start & finish but the darn TQI stuff wont link call TRAXXAS up again & I was asked by the TECH if I am using an Android based system I said yes. The Tech that is half my problem for some reason Android APPS don't work well on the TRAXXAS LINK System the tech said I should find a friend that has an APPLE product such as a tablet to download the Firmware Than after that the DTS-1 should operate normal.

    Well I don't know anyone that has an apple phone so never got chance to download the firmware

    But the DTS-1 works fine in plane mode
    Think I tried everything except turning on airplane mode, thanks! Youve given me hope and if that doesnt work both my daughters have iphones so Ill try that too! Its been sitting collecting dust maybe I can actually use it now. Sorry to hear about your luck but thanks for posting this to help me and hopefully others as well! Keeping fingers crossed airplane mode continues to work....

    I need just one more rc, then Im done,
    Just need one more rc, then Ill be done...

  3. #3
    RC poster
    Join Date
    May 2017
    Location
    Minnesota
    Posts
    4
    They work awesome, they are tricky to set up each time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •