Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Mar 2017
    Posts
    4

    X Maxx stopped working

    I'm new to the rc world as I just won a xmaxx in a raffle and took it out for he first time today and accidentally flipped it. Wasn't going to fast but ever since I can't get the controller to sync. The transmitter and receiver lights keep flashing red. If I try to sync them it will go green for a split second that back to flashing red. Any suggestions? Thanks

  2. #2
    RC Champion fourdub's Avatar
    Join Date
    Jan 2016
    Location
    Colton, Inland Empire, Southern California
    Posts
    1,902
    Hello EVojay88!

    Welcome to the forums!

    When you try to sync it, what steps are you taking?

    What I would suggest is:

    opening the receiver box, and taking the esc and steering plugs out of the receiver. inspecting the plugs and re-inserting back into the revicever.

    the first two slots are channel 1, channel 1 is for turn, the next channel is channel 2 that is to go forward and backs. Good way to remember this is 1 is for turn, 2 is for burn.

    After re-seating them try it again. if that dosent work, reset the controller and receiver by:

    unplugging the battery on the truck, replugging it back in.
    turn on the remote WHILE holding the set button. the remote with flash red.

    hold the reset button the receiver box, and turn the truck on, this will re-pair the controller and truck.

    If you have already tried the above please post again and we can go from there!

    welcome to the forum!

    fourdub
    Sla2hvxl,pe4evxl,erevobl
    "Richard Chilson"youtube

  3. #3
    RC poster
    Join Date
    Mar 2017
    Posts
    4
    Thanks for the reply! I have tried doing that with no luck. It will pair for a split second then go right back to flashing red. It sucks because it was my first time using it!

  4. #4
    RC Champion fourdub's Avatar
    Join Date
    Jan 2016
    Location
    Colton, Inland Empire, Southern California
    Posts
    1,902
    yeah sorry it looks like you are going to have to call traxxas.

    did you by chance drive the truck thru water or wet grass? the only times I've experienced what your explaining is when my receiver box gets wet on my stampede or slash. usally after a day or two it drys out and works again.

    just another thought.

    Traxxas will take care of you. Is your truck branded? Snap-On, Kawasaki, Or just a "red" or "blue" ?

    Congrats on your win, you will be up and running again soon. the trucks are awesome.
    Sla2hvxl,pe4evxl,erevobl
    "Richard Chilson"youtube

  5. #5
    RC poster
    Join Date
    Mar 2017
    Posts
    4
    It is a snap on truck. Completely shocked I won it. It wasn't driven through any water at all just dry grass.

  6. #6
    RC Champion fourdub's Avatar
    Join Date
    Jan 2016
    Location
    Colton, Inland Empire, Southern California
    Posts
    1,902
    yeah give traxxas a call in a few hours when they open, they will take good care of you!!!
    Sla2hvxl,pe4evxl,erevobl
    "Richard Chilson"youtube

  7. #7
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    Mojave Desert
    Posts
    3,013
    Have you read the manual and diagnosed what the flashing lights mean?
    We are all one race. The human race.

  8. #8
    RC poster
    Join Date
    Mar 2017
    Posts
    4
    No I have not. I looked through the books trying to find something but no luck. Maybe I missed it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •