Results 1 to 12 of 12
  1. #1
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496

    PLEASE HELP!! ESC blinking Green...

    Hey Everybody!
    So Here I am on my Vacation. I posted a thread a while ago asking what I should bring. Well, I didn't buy anything for the trip, and so far I haven't broken anything.. I think. Anyway, Late here, so I was doing some speed runs on a nice road when I decided to try to video camera while driving. Long Story Short, I started to turn, and instead of dropping my phone, I let go of the throttle and tried to turn it. Didn't make it in time and it crashed into the curb. Well, I thought it would be fine considering I jumped it over my pool 2 times, but the 2nd time didn't make it. Well, I had no steering and throttle response so before I got run over by a car,(Very slow street. Great for speed runs) I took it to the side walk where I could take the body off. Well, the esc was blinking green very fast. Some people that I read said to make sure my Battery was charged, so I took it in and charged it. I just plugged it in and I'm still getting no response. Does anybody know what the problem is?
    Thanks,
    Traxxas9008
    If you ain't getting dirty, you ain't having fun.

  2. #2
    RC Racer h2rac3r's Avatar
    Join Date
    Dec 2016
    Location
    South Jersey
    Posts
    223
    May be the esc needs recalibration. Controller batteries are dead, possibly. Change the controller batteries. Controller=transmitter.

    Sent from my SCH-I545 using Tapatalk
    When I ain't at school I'm racing my Slash

  3. #3
    RC Turnbuckle Jr. billy-bones's Avatar
    Join Date
    Nov 2012
    Location
    Michigan
    Posts
    8,203
    Quote Originally Posted by h2rac3r View Post
    May be the esc needs recalibration. Controller batteries are dead, possibly. Change the controller batteries. Controller=transmitter.

    Sent from my SCH-I545 using Tapatalk
    Sounds right to me, pretty sure the fast green blinking light means your neutral point are off.
    Built Ford Tuff With Chevy Stuff.

  4. #4
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496
    Okay. So I looked up how to Calibrate my ESC on Traxxas. Well, I held it until it was Red. Then I left it and prepared to pull the throttle. Well, It never blinked so I turned it off. Next, I Held it until it was red but continued to hold it. Then, it finally Blinked Red so I let go and pulled the throttle. A soon as I let go of the button and pulled the throttle, it went back to blinking green. I kept holding it for a long time but nothing happened. I don't think my Batteries are dead because my light is still green and it usually turns red or something if they are dead or not connected. Any more suggestions?
    If you ain't getting dirty, you ain't having fun.

  5. #5
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496
    Would water getting into my Receiver do it? Maybe wreck it or something?
    If you ain't getting dirty, you ain't having fun.

  6. #6
    RC Racer h2rac3r's Avatar
    Join Date
    Dec 2016
    Location
    South Jersey
    Posts
    223
    It's waterproof. It would be fine. Check if the wire connecting the esc and the receiver is in the right spot.

    Sent from my SCH-I545 using Tapatalk
    When I ain't at school I'm racing my Slash

  7. #7
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496
    I plugged them all into different channels and it still blinked green very rapidly. Is the light on my Receiver green or red? And is the receiver out of the box still waterproof?
    If you ain't getting dirty, you ain't having fun.

  8. #8
    RC Racer h2rac3r's Avatar
    Join Date
    Dec 2016
    Location
    South Jersey
    Posts
    223
    Yes.

    Sent from my SCH-I545 using Tapatalk
    When I ain't at school I'm racing my Slash

  9. #9
    RC Racer h2rac3r's Avatar
    Join Date
    Dec 2016
    Location
    South Jersey
    Posts
    223
    Try setting it to the programming mode and see if that works at all. If it doesn't post a video on what you are doing, you might be doing something wrong.
    When I ain't at school I'm racing my Slash

  10. #10
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496
    Thanks. No Idea how, but I just turned my Slash on and it drove. I was about to try a few things a read about when it just worked. Maybe I did something last time? I believe last time I was unplugging everything from the receiver and plugging them back in. The receiver was green when I turned it on and the esc was a solid red. So happy! I took it out for a nice long slow walk. Found a few good places to do some good drifting on some dirt and sand.
    If you ain't getting dirty, you ain't having fun.

  11. #11
    RC Qualifier Traxxas9008's Avatar
    Join Date
    Sep 2016
    Location
    British Columbia
    Posts
    496
    Okay, it finally worked. But now, it fell into the pool again after doing some drifts and when I was driving it back, the Receiver went solid RED and the esc was blinking Green. I switched the batteries out on the Transmitter, but it still isn't working. And I can't re-calibrate the system if my Transmitter and Receiver won't connect! PLEASE HELP! Is the Receiver out of the box still waterproof? Because there was water inside the box. (Not much. Just a few).
    PLEASE HELP! Is my Receiver... *gulp* dead?!?!?
    If you ain't getting dirty, you ain't having fun.

  12. #12
    RC Racer h2rac3r's Avatar
    Join Date
    Dec 2016
    Location
    South Jersey
    Posts
    223

    Unhappy

    Just take it out and dry it. And yes it is waterproof RTR. I think that you might not have tightened the receiver box tight enough. It might be dead sadly but just upgrade it to something better. Not sure what is better or maybe you could get a Traxxas receiver and transmitter combo. https://traxxas.com/products/parts/t...traxxaslink4ch TSM 5 channel receiver and a 4 channel transmitter. Room for telemetry and lights. That's the one I'm gonna get. Just dry it, reconnect all wires leading to the receiver and if that doesn't do it, I'm afraid it's dead, my friend.
    Last edited by h2rac3r; 05-22-2017 at 04:43 PM. Reason: added stuff
    When I ain't at school I'm racing my Slash

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •