Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Jun 2017
    Posts
    9

    Question Savox SAVSW0250MG Quality

    I'm looking to get a new, better servo for my my MERV VXL, as I've had to replace the gears about 8 times now in 1 week. I think I'm going to get the Savox SAVSW0250MG, as that seems to have the specs I want. I only had one question. The price seems to be a little low for what is described. Is it just a good price? Or is it not as good as it sounds?

  2. #2
    RC Champion
    Join Date
    May 2002
    Location
    Midvale Utah
    Posts
    1,773
    It's awesome. Honestly the best you can get for the merv
    Dacaur

  3. #3
    RC poster
    Join Date
    Jun 2017
    Posts
    9
    Thanks! Will definitely be getting one!
    You haven't lived tell you've crashed

  4. #4
    RC Racer
    Join Date
    Aug 2014
    Posts
    105
    As I said In the other thread...I've had four of these replacing the crap 1/16 traxxas stockers and I've never had one fail on me. Been a couple years at least.

  5. #5
    RC poster
    Join Date
    Jun 2017
    Posts
    9
    Just got one ordered! Thanks for the quick replies!
    You haven't lived tell you've crashed

  6. #6
    RC poster
    Join Date
    May 2016
    Location
    A Cardboard Box
    Posts
    5
    Nice decision! I had mine for 2 months, and a single mg servo is the way to go. Don't do dual savox servos though, it uses too much voltage, not worth doing for a mini.

  7. #7
    RC poster
    Join Date
    Jun 2017
    Posts
    9
    I took the car out this morning for the first time with the new servo, and it would turn as tight as it could, but it wouldn't go back to neutral. The esc also had a solid red and was emitting a noise the entire time. I only ran it for about one minute before I brought it back in. Does anyone know what the issue is?
    You haven't lived tell you've crashed

  8. #8
    RC Champion
    Join Date
    May 2002
    Location
    Midvale Utah
    Posts
    1,773
    Most likley a defective servo.
    Dacaur

  9. #9
    RC poster
    Join Date
    Jun 2017
    Posts
    9
    Quote Originally Posted by dacaur View Post
    Most likley a defective servo.
    I have reversed the steering now(forgot to before), and it goes back to neutral just fine now. The noise isn't so loud and I'm now thinking that it's just the servo. I had to take apart the car because I had a high-pitched noise that I believed to be grinding from the diffs. turned out that I just needed to re-adjust the slipper clutch.
    You haven't lived tell you've crashed

  10. #10
    RC Champion
    Join Date
    May 2002
    Location
    Midvale Utah
    Posts
    1,773
    Having the servo reversed wouldn't cause that, but good that its fixed....
    Dacaur

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •