Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Jul 2017
    Posts
    1

    Bought a Summit on ebay now it doesnt work - no forward or reverse

    Hi, I bought a Summit on Ebay - trying to find hobbies me and my Son can do together, so we got a Summit and had a blast for about 20 minutes in a dis-used Quarry locally.

    We bought an FTX Surge cheaply which kept breaking, so I researched what truck is tough and the internet said "Summit" so I got one of them and we have had no end of problems trying to get it running.

    We had fun and want to continue with our Summit, purchased on Ebay for 300, we got a pair of 5000 nihm 8.4v batteries and charger for another 100 from Modelsport in the UK which they recommended we buy as newbies rather than lipo.

    Then the truck stops working, it wont go forward or reverse - the ESC flashes red/green which I understand to be a high voltage warning ? truck not running due to too much Voltage? I think previous owner was running Lipo and had a low voltage warning on and now we are back on Nihm batteries the car does not like it.

    I have tried about 20 times to recalibrate the ECS and switch the voltage back to nihm batteries - nothing works, I mailed Traxxas but there is no response, I facebook messenged Traxxas and Modelsport but no response, I mailed Modelsport the videos of the problem and there is no response - I offered to pay service/maintenance charges but no one wants to fix the truck for , I cannot call the Traxxas helpline as my mobile phone does not allow international calls.

    Do I need a new ESC? its 160 ! it was sold to me as a running car so im tempted to return the truck to the ebay seller and try and get my money back - but that still leaves me and the boy with no truck and also a set of new batteries we have no use for

    So my kid keeps asking me when the truck will be fixed, its frustrating because my main hobby is full size race cars which I have built myself - but the little car I cant seem to fix !

    Any suggestions would be really appreciated, thank you

  2. #2
    RC Qualifier czlynx's Avatar
    Join Date
    Jan 2016
    Posts
    459
    Quote Originally Posted by Newsummituser View Post
    Hi, I bought a Summit on Ebay - trying to find hobbies me and my Son can do together, so we got a Summit and had a blast for about 20 minutes in a dis-used Quarry locally.

    We bought an FTX Surge cheaply which kept breaking, so I researched what truck is tough and the internet said "Summit" so I got one of them and we have had no end of problems trying to get it running.

    We had fun and want to continue with our Summit, purchased on Ebay for 300, we got a pair of 5000 nihm 8.4v batteries and charger for another 100 from Modelsport in the UK which they recommended we buy as newbies rather than lipo.

    Then the truck stops working, it wont go forward or reverse - the ESC flashes red/green which I understand to be a high voltage warning ? truck not running due to too much Voltage? I think previous owner was running Lipo and had a low voltage warning on and now we are back on Nihm batteries the car does not like it.

    I have tried about 20 times to recalibrate the ECS and switch the voltage back to nihm batteries - nothing works, I mailed Traxxas but there is no response, I facebook messenged Traxxas and Modelsport but no response, I mailed Modelsport the videos of the problem and there is no response - I offered to pay service/maintenance charges but no one wants to fix the truck for , I cannot call the Traxxas helpline as my mobile phone does not allow international calls.

    Do I need a new ESC? its 160 ! it was sold to me as a running car so im tempted to return the truck to the ebay seller and try and get my money back - but that still leaves me and the boy with no truck and also a set of new batteries we have no use for

    So my kid keeps asking me when the truck will be fixed, its frustrating because my main hobby is full size race cars which I have built myself - but the little car I cant seem to fix !

    Any suggestions would be really appreciated, thank you
    Sorry you're having issues! The summit is a great truck but buying one used is a bit of a gamble. Mine was described as ready to go, but needed work right away. Nothing big but it would have been frustrating if it was my first rc.

    Take a look at post 20 in this thread and see if it helps.

    https://forums.traxxas.com/showthrea...898-evx-2-help!

  3. #3
    RC poster
    Join Date
    Jan 2017
    Posts
    9
    My summit does the same thing
    I think they all do. After I run it and the batteries have discharged my ESC flashes red and green if low voltage detection is on (green LED). It flashes red only if low voltage detection is off when I use my NIMH batts. No where in the manual does it tell you how to stop it. Even Traxxas seems oblivious to this. You need to turn low voltage detection off. The easiest way to do this is to unplug your NIMHs while ESC is on and plug in two charged LIPOs then turn it on again. It should now have a steady green and you're good to go. No LIPOs? You're screwed. Just kidding. There is a video on YouTube from a little brainiac kid. Just search for "summit flashing red and green". Here's the rundown. Turn on your ESC and if you have red and green flashing, unplug one battery only. If you do the right one the LEDs will still be on. Hurry and press and hold the button for ten seconds and ESC should change to red. Unplug your batts, fully charge and you should be good to go. But check out that video on YouTube. I've tried it and I had to play around a bit but it did work for me. Good luck.

  4. #4
    RC Qualifier Rich2's Avatar
    Join Date
    Feb 2014
    Location
    Western New York
    Posts
    628
    Quote Originally Posted by Newsummituser View Post
    Hi, I bought a Summit on Ebay - trying to find hobbies me and my Son can do together, so we got a Summit and had a blast for about 20 minutes in a dis-used Quarry locally.

    We bought an FTX Surge cheaply which kept breaking, so I researched what truck is tough and the internet said "Summit" so I got one of them and we have had no end of problems trying to get it running.

    We had fun and want to continue with our Summit, purchased on Ebay for 300, we got a pair of 5000 nihm 8.4v batteries and charger for another 100 from Modelsport in the UK which they recommended we buy as newbies rather than lipo.

    Then the truck stops working, it wont go forward or reverse - the ESC flashes red/green which I understand to be a high voltage warning ? truck not running due to too much Voltage? I think previous owner was running Lipo and had a low voltage warning on and now we are back on Nihm batteries the car does not like it.

    I have tried about 20 times to recalibrate the ECS and switch the voltage back to nihm batteries - nothing works, I mailed Traxxas but there is no response, I facebook messenged Traxxas and Modelsport but no response, I mailed Modelsport the videos of the problem and there is no response - I offered to pay service/maintenance charges but no one wants to fix the truck for , I cannot call the Traxxas helpline as my mobile phone does not allow international calls.

    Do I need a new ESC? its 160 ! it was sold to me as a running car so im tempted to return the truck to the ebay seller and try and get my money back - but that still leaves me and the boy with no truck and also a set of new batteries we have no use for

    So my kid keeps asking me when the truck will be fixed, its frustrating because my main hobby is full size race cars which I have built myself - but the little car I cant seem to fix !

    Any suggestions would be really appreciated, thank you
    You will need to put a LiPo battery back in it in order to reset it for NiMH.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •