Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jul 2017
    Posts
    2

    E-Revo 1/16 - Electronics Issue - Need Help, ESC, Steering Servo, Radio, etc

    Hi All,

    Here is the issue.
    I have ERevo 1/16 with stock motor, stock radio, 60A esc, 390 steering servo.
    When I connect to lipo 2s or 3s battery, everything powers on, controller, receiver, esc.
    1st Issue: I press throttle (forward), motor runs forward and stops but reversing the throttle on controller does not reverse motor and turning steering on controller does not turn - NO movement in steering servo.
    2nd Issue: I press reverse throttle and sometimes it reverses sometime it does not reverse. Still no steering movement at all.

    History: The set up was running fine, till kids ran it on grass and it stopped. I thought the battery needed changed. Put another 2S battery and it shuddered and smoked, unplugged immediately and then it sat for sometime before I got time to fixing it up again.

    The motor seems fine.
    The radio receiver on the car seems fine (I have reset the controller already).
    I am thinking its either the esc or the steering servo.
    FYI, I have tried a different 60A esc which show same above mentioned issues and NO steering at all.

    Can anyone help me, put this beast back together?
    Is there anyway to check if the steering servo is good or bad?
    What are my options?
    Help

  2. #2
    RC Turnbuckle Jr. Petertje60's Avatar
    Join Date
    Jan 2011
    Location
    Rotterdam, Netherlands
    Posts
    8,617
    The history part tells me that you might have a faulty ESC at the moment. A broken servo can cause weird problems with your ESC, so worst case the servo burned up and after that the ESC got some problems.

    Just to be sure: is the servo connected to the right slot in the receiver?

    Not sure if you tried that yet, but you could try recalibrating the ESC/transmitter.

    Last but not least: Welcome to the forum!
    Nobody is born with experience

  3. #3
    RC Competitor
    Join Date
    Jun 2011
    Location
    watertown ny
    Posts
    95
    I would unplug steer servo an c how esc acts my servo went up an would not allow esc to do much of anything also check the wires from esc to motor had one that was a lil lose an whould cause esc to perform erratic if servo is shot i would suggest goin with a savox 0250mg unit mines been good sobfar

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •